Kodi Not Connecting

I have written several times before to no avail, but am really hoping it works this time. My issue is Kodi. Every time I have entered a new source, named it and clicked OK, I get this screen that says “Unable to connect.” I have reset my modem, reset my Dish Hopper and reset my Fire Stick. Same result. I have tried to use both the 19.5 and 19.4 versions. Same result. I have checked my internet connection and speed and they are both fine. CAN YOU PLEASE HELP ME???

1 Like

Please try this for Kodi the 9.5.


It is working

What source are you entering? You can take the url you’re using and check it in a browser to make sure it is actually working/connecting. You may have a typo in the url or you may be entering an old source that’s no longer there.

The source for kodi 19.5 is


Kodi mega guide.

Try connecting to a VPN first. That looks like the correct link to the repo. Might be blocked by your ISP? If that doesn’t work then lookup how to completely delete the Kodi settings file. Sometimes deleting the app and reinstalling it isn’t enough.

Want to thank all the “insiders” for their suggestions. I used my iPad and entered the URL I was using and it said - bad gateway. I then tried another and it worked. Again, thank you all for your replies and suggestions! JR

I had the same problem with http:diggz1.me/diggz19/ worked great last month, try https:1//diggz1.me/diggzrepo/ worked for me:,

This topic was automatically closed after 7 days. New replies are no longer allowed.