How to Disable Play Protect on Android TV Devices

Originally published at: How to Disable Play Protect on Android TV Devices

This guide shows How to Disable Play Protect on Android TV devices. We have seen several comments on the TROYPOINT website lately from users who are having issues side-loading applications onto their Android TV devices due to a play protect issue. It appears there have been some recent updates to Google Play Protect, as more…


Thank you…will do this after work

@Miki is a FireTV an android? I don’t use Google Play, The instructions in the link seem to be fore Nvidia or Mecool. Is disabling play relevant to FireTV?

No. FireTV OS uses the Amazon store.

That doesn’t work. There is no " Verify apps toggle" under Security & Restrictions. however, there is something of the sort in Developer Options named "Verify apps over USB, but it is greyed out.

you saying your using a nvidia shield pro but my shield does not have a Security & restrictions section under Device Preferences let alone verify apps toggle to turn off play protect but it is in my newsletter so if this is old content it needs to be updated because it does not relate to current shield options

Go directly to Play Store and disable there. Worked for me.

The problem I am having with the instructions is some of the areas where your supposed to turn off stuff isn’t there. I have a KM7 MsCool. The sections are elsewhere and there isn’t anywhere where you can disable play protect. I keep trying to download UKTurks and it keeps giving me the warning about a fake site, etc…

Fixed!! I just had to go into the play store like Powerfader showed. Al is good in my part of the world

1 Like

In the last 24 hours google play protect has deleted my sportsfire apk and is blocking any reinstall, the instructions on this forum are not working either , has google clamped down on sportsfire . I can’t even turn off play protect, In UK using Ipvanish and changing location doesn’t work either. Does anyone have a work around, it’s still working on my firestick

What device are you using and what have you tried? You should be able to go into the playstore and turn off playprotect and app scanning. I do both on my Shield Pro.

1 Like

After downloading the apk using Downloader , google does not give me the option to “download anyway “ on the drop menu as it insists that the apk is harmful. Tried this on both my 2019 shield and my anti my TCL Android tv , still installing on my firesticks

You disable play protect first, before any download of the APK.

Open the playstore on your device. Click your icon top right. Then disable the options as in the picture below.

1 Like

Thanks miki problem solved :+1:

Sadly, neither of these options are available on my TiVo Stream 4K. Anybody know how to roll the OS back to an earlier version where Play Protect can be disabled?

Same problem as @Badwine . It also does not help to go to Android settings > Apps > Security & Restrictions > turn off Verify apps
Play Protect is still on and no way to turn it off and icon to do so under the name icon in Playstore, as that option is not there.
So…if you solve this mystery, please let us know !

The option to turn off Verify apps is under Apps - not Device Preferences - as referenced in the instructions above. The TiVo seems to be different.
I had no trouble disabling Play Protect on Nvidia or Fire Cube and the instructions above are correct for those devices

I downloaded Flix vision and it worked great turned off my android box ( pendoo x12 pro ) turned it back on and the app was gone completely had to download again , worked great, shutdown than started back up same thing disappeared
Can someone please help :pleading_face:

You must turn off Google’s Play Protect … Much discussion on how to do this in other posts

1 Like