Resolve URL Error Real-Debrid

I cannot connect my FireStick - Kodi- The Crew. I keep getting the same Resolve URL error and then told to ‘check the log’. I would not know what to look for in the ‘log’ or where it is located. This is a fresh install of ‘The Crew’ on a recently reset to factory defaults FireStick 4K and I have had a Real Debrid account for some time now.

1 Like

Look here… tis on the home page

1 Like


By the time I saw your response, I had already cleared all the data in Kodi and started a fresh install of The Crew. The first thing I did after the install was try to connect to Real-Debrid. For some reason, it worked this time and I now get what I expect when I search for a movie.
Also, I’m a geek who worked on large IBM systems for 30 years. Hence the id - iSeries430
Thanks for your help.

Ok Jayhawk, which one we do , this one or your previous fix.

1 Like

I’m testing the updated information on my fire stick right now to see if it works. Let you know in a few minutes.

1 Like

Thanks, I got it working now. I tried the ‘Microsoft Protocol’ (Turn it off, turn it back on) by doing a fresh install of The Crew. Real Debrid seems to be working OK now. Thanks again.

1 Like

Ok appreciate ya, be anxiously awaiting :joy:

It appears it has been officially fixed. I didn’t even touch my fire stick. All I did was reboot my device and it was working again. Try doing that and see if it works.

If it doesn’t work, follow the steps I posted in regard to the part where you turn off auto updates for ResolveURL, go to configure, clear the settings and function cache, then go back to versions and reinstall it from the crew repo. Then remember to change your settings back and reauthorize RD.

1 Like

Glad its working, if anyone has issues with crew or seren with real debrid, consider a vpn and stremio as a backup just incase.

Ok, yea the other day before I posted I did a restart on the stick it didn’t fix. That’s the reboot ur talkin right ?

I run my vpn all the time. Just habit👍

1 Like

Hey Jayhawk have you done anything new to your update on the crew setup since I last viewed. ??

The issue was just fixed last night or this morning. It was something that changed with Real Debrid. Please restart your device and let me know if it works or not.

I have not changed anything with the crew setup. The settings are all the same now that the issue with real debrid is fixed. The only thing I have done since putting out that video is switch to a different skin and use some widgets.

1 Like

Still seem to be having issues with playback errors and line errors in MD and Asgard. Have tried both solutions… couple of times. Not sure what to do to correct it. All was working fine couple of days ago.

Did you delete the settings file, force close, and reauthorize?

Yeah…keep getting Asgard and MD errors

Just re did it and updated using the Crew repo version, reauthorized and got a line 2920 error when trying to open a movie link.

I’m out of ideas then. You can always use the backup addon from the official Kodi repository to backup everything and then start all over with a fresh copy and see if it works. Or install the Troypoint fork of 19.0 and see if a fresh install of the crew works with that.

1 Like

But your crew is working now right??