Real Debrid causes "No Streams Available"

I was using Real Debrid with Kodi 18.9. on a Firestick 4K. My addons were The Crew, The Oath, Numbers, and Venom. I was getting tons of great links. Things were great!
Suddenly, nothing worked anymore. I still get all of the links, but instead of playing a link it goes into another search that ends with “No Streams Available”. This happens with all of my addons.
Clearing cache, restarting router didn’t work.
Installed Kodi 19.1 and reinstalled The Crew. Same problem.
When I disable Real Debrid, it works again. Very few links, but it works. When I enable Real Debrid, it’s back to tons of links but “No Streams Available”.
I’m baffled…HELP!!!

Subscription probably expired.

1 Like

Nope. I just renewed a couple of months ago…

By the way, I’m using IPVanish.

Re-authorize the account if you haven’t already then check your settings.

Someone else also posted recently that they did a firestick update and now they can’t get anything to play. I wonder if Amazon has done something :thinking:

@Jayhawks659
@cableBgone

I m curious if Amazon has done something as well.

My suggestion would be to try kodi with your addons and debrid on another device. If it works you have your answer.

1 Like

The only time I’ve ever been able to search for RD links but not play them is when my subscription expired. When you click on a link it will just keep skipping to the next link until you’ve reached the end. If there aren’t any free links available then you’ll get the message that says no streams available.

If you haven’t already, just double check. Login with real-debrid.com and look at the top to make sure it says premium and a future expiration date. If all of your addons are not working in Kodi then it’s either real-debrid or your ResolveURL settings.

1 Like

Also try changing your VPN protocol and see if that does anything. Or try it without the VPN at all and see if it still happens.

1 Like

Are you using a build for Kodi?

No build. New install of Kodi 19.1. New install of latest The Crew addon.

I’m getting bad vibes. Hoping you can find a fix to this and it isn’t something that is going to impact a ton of other users. You double/triple checked your RD account already? Are you at the point yet of doing a hard reset of the firestick and starting over from scratch?

@Jayhawks659

I did some research regarding this and nothing suggest they did anything. However comments where made that amazon is going to fight “illegal services” through updates.

So it could have been a secret thing. You can rollback your software update and I can provide a guide for that.

That’s exactly what I’m afraid of. Didn’t think it would be happening so soon. I disabled automatic updates on mine. I have a firestick in my bedroom but a shield in the living room. I’m not going to update anything on the firestick unless something stops working.

You just might be right after all.
I forgot that it’s only a 3 month subscription.
I was thinking of a yearly subscription like IPvanish.
I’ll check it out and let you know.

1 Like

Someone mentioned the other day that you can buy multiple subscriptions at a time and stack them up. It just adds more time. It will still expire eventually. Just set a reminder on your phone to renew before it runs out. And of course if it gets shut down at some point I doubt you’ll get a refund for unused time. I just do 6 months at a time.

3 Likes

You can stack them. I did this yesterday.

@Jayhawks659

1 Like

I’m getting no streams available on certain shows. I figured it was because they took stream mango and other services down and maybe Real Debrid was using those. Is anyone else experiencing this?

@Kelz

What device are you streaming on? Also make sure your rd subscription isn’t up. They don’t warn you. It just ends.

No rd links? Check subscription

What streaming service you using?

Yay! Happy ending!
Turns out that my Real Debrid subscription expired!
Thanks to all of you who replied with helpful advice!
(As a bonus, I wound up with the latest version of Kodi!) :wink::face_with_hand_over_mouth::upside_down_face:

1 Like