KODI 20 with THE CREW = loads no good links

Are people dumping Kodi 20? The Crew has no good links. They simply do not load.

RD is apparently a joke too. It offers over 100 links (in magenta) and none work.


hi i have kodi 20 crew works fine on it maybe delete crew and reinstall it


Why would I dump it. It works perfectly here and Real-debrid is giving plenty of working links.



There must be something you’re doing that I’m not.

I have tried with and without RD.

I’ve tried with and without Superman.

Regardless — there is either NO LINK WHATSOEVER or there is but it’s not a good link.

Hello, Pirate77,

I tried this too.

I can find links on CINEMA that sometimes work. Upgrading to Cinema 2.5 or higher was risky too.

It is almost more effective to belong to a foreign movie-tv club.

Do you think that because I have CINEMA on the FIRESTICK 4, it scans for Kodi and disables the links on Kodi ?

1 Like

no i have cinema as well all fine one thing thing is i never use a build on kodi much better to load your own apps and use stand alone apps as well if you keep having problems i would delete all and start over

1 Like

KODI 20 and RD has been working flawlessly for weeks

Avid Kodi user with real debrid here and all is working fine.

There is nothing wrong with The Crew.

I would suggest sticking with cached torrents instead of hoster results, as they are much more reliable.

Yes the addon will skip over many unreliable hoster links but some still work fine.


I’m a neophyte.

First I added Kodi.

Then I added The Crew
Then I added RD

I am unsure what you’re saying about torrent.

On the page where I enable RD, there is a toggle switch for TORRENT. Are you saying this needs to be ENABLED or DISABLED?


Do you use Kodi 20 with RD and you do not use Crew? What are you using in lieu of THE CREW?

Do you enable TORRENT on the Kodi 20 app?

1 Like

I use KODI 20.1 + RD and use both The Crew and 9Lives Addons mostly 9Lives as of late. I have a Build and I also have the Troypoint Fork installed

If you want to maximize results then both hoster links and cached torrents should be enabled when setting up real debrid and the resolver the addon is using.

1 Like

Thanks, I love these Kodi tutorials.


I have had the same problem. Reset the whole fire stick. I’ve done 3 different builds with different add ons. Some will show links then say no links. Some will show I think it’s the cshare link but it plays older episodes. I’m at a loss too.

1 Like

Crew works just fine. So does Real Debrid. I find hundreds of premium links every movie I search.


Problem is on your end The Crew is working perfect. Delete everything on the Firestick and start over. Still not working? Buy a $20 4K ONN Box, throw stick in rubbish


I am not sure if we are saying some similar.

I only downloaded Cinema, The Crew, Kodi, Downloader. I removed RD because that was trashed from day 1.

I have a VPN downloaded as well.

Subscriptions to any service are downloaded to the tv not the Firestick.

I purchased Firesticks for all the TVs.

Getting Onn will move the problem. Within 8to12 months, Onn will have the same issues.

How are you “deleting” everything off the FS? Do you mean uninstall?

Just out of curiosity, are you using a VPN that’s compatible with Real-debrid? Because it’s pulled tons of links on over 30 different addons for years flawlessly for me.

“I removed RD because that was trashed from day 1” Okay I really don’t understand what you are saying or meaning to say with this. But NOT having RD or some other premium debrid service is your first issue here if you are using KODI.

1 Like