Is Surfshark blocking YouTube on Amazon Firestick?

Just recently (I think it started this June), I noticed that YouTube app doesn’t work in my Amazon Firestick Max when Surfshark VPN is active (doesn’t matter which server/country you are connected to). Even youtube.com won’t load from Silk browser. But as soon as I disconnect Surfshark, YouTube works again! I tried this from my other Amazon Firestick 4K device and I am getting the same issue. Strangely, I don’t get this problem when I run Surfshark from my mobile phone and laptop as I am still able to access YouTube either from the app or from the browser while Surfshark VPN is running. I have also tried another VPN provider and it lets me use YouTube from my Firestick devices while VPN is on. I wonder if Surfshark has done any recent update which is now blocking YouTube. I tried installing an old Surfshark apk but it still won’t let me use YouTube so long as I’m connected to VPN :frowning:

2 Likes

Thats because these paid apps dont work well with vpns on… split tunnel to thse apps

2 Likes

Thanks for the feedback but as I have mentioned, I tried another VPN provider and YouTube works fine. Also, SmartTube (which is not a paid app) doesn’t work either. I’m curious if any other Surfshark users with Amazon Firestick are having the same issue. I tried to report this to Surfshark customer service but instead of trying to replicate it themselves (which is very easy), they just asked me to do a lot of things which never addressed the issue. If they don’t fix this I think it is time that I ditch Surfshark and get another VPN provider.

BTW, I checked out the Split Tunneling thread and read “…Split tunneling allows for an “App” to access the internet without going through a VPN server.”

Actually, I need to connect to a VPN server while running YouTube as I want to access a livestream content which is only available from a host country. So if split tunneling will just bypass VPN to make YouTube work again, then I think it doesn’t solve my problem. :frowning:

I have Surfshark and SmartTube. So I tried the following. I loaded SmartTube and it failed. I used bypassed the VPN and it worked. I also tried this: I set SmartTube location to Argentina and then SurfShark to Argentina and it work fine.
So maybe worth setting SmartTube or YouTube location to the country the streaming the live content and then change SurfShark to a server in that country :+1:

1 Like

Just try different servers and dns if possible. Usually you will find one that works.

1 Like

Thanks for confirming that you are getting the same issue. Just now I tried exactly what you mentioned. I set my SmartTube’s country to Argentina and then I connected my Surfshark to Argentina. It still won’t load.

From Surfshark app, I then turned on the bypass VPN setting and have added SmartTube in the app list. As expected, SmartTube worked (but clearly, it is like working with my VPN turned off).

Then from the Surfshark app, I turned off the bypass VPN setting. But I did not remove SmartTube from the bypass list. SmartTube worked even though the bypass VPN setting is turned off. But I noticed that it is not showing the livestream video from the country that I am currently connected to via VPN. I went back to Surfshark app and removed SmartTube from the bypass list and I kept the bypass VPN setting turned off. This time, SmartTube won’t work.

Therefore, it seems that so long as an app is in the bypass list, VPN will be bypassed for that app whether or not the bypass VPN setting is on or off. I suspect that when you tried to connect to Argentina while your SmartTube app is set to Argentina, SmartTube is still in your bypass list that’s why it is working for you.

1 Like

That is exactly what Surfshark Customer support asked me to do but to no avail. I really think something has changed, probably from YouTube side. Somehow, it seems like it blocks all IPs issued by Surfshark. Though only Firestick devices are affected so far because I don’t get this issue from my tablet or mobile device.

yes the tech changes at a rapid rate now days… you might try a mac changer. Not sure how much google ties to your mac but its possible just changing mac(you) could help.

edit… the reasoning im using here is the other devices work…so maybe a face lift

Two of my firestick devices exhibit the same problem. And another one here was able to replicate the issue that I mentioned. So I doubt that changing the mac address would help .

It is a strange one for sure. SmartTube won’t work for me with a UK server in SurfShark. I’m based in the UK :face_with_raised_eyebrow: It does work if added to the bypass list. What is odd, I get it working if Sufshark and SmartTube are both using a server based in the same country, except the UK, my own country :unamused:. I tried France, Bolivia, Canada and the USA. All worked fine with Surfshark on, SmartTube set to that same country.

I get what your saying but most paid apps inculding youtube will not allow you to run a vpn effectively. If you want other country stuff i suggest iptv or simply using real debrid and search it in a app that offers tv shows and movies.

Take a look here for the best recommend aps with real debrid setup.

I hope you get the issue resolved.

1 Like

Thanks for the suggestion. Unfortunately, the livestream videos that I want to watch is only available in YouTube. I guess it’s about time that I get a new VPN provider.

Surfshark is rated as one of the very best VPN’s. I’m not sure there’s a VPN provider that would satisfy everyone. I guess you have to just assess which one suits your needs.

1 Like

You can get many browsers that have YouTube built in to them that do work with Surfshark . Puffin browser is just one . Their are many more .

2 Likes

Yes same here on my end as well! I’m a SurfShark user and have noticed this happening as well! It got me to thinking about the recent line of events that have been going on lately with the world and all of the vpns not just this one! There are several of these vpn companies that are pulling their servers from certain places because of their laws changing regarding the use of vpns and these places are demanding that they have access to everyone’s info so that they can monitor what and how content is being accessed in their country’s and with the rules and policies that our vpns have put forth to their customers they are refusing to give up OUR info and so they are basically forced to just shut down and pull their servers from these places!! I personally am not “blaming” these vpn companies for doing exactly what we pay them for by no means….
As a matter of fact I’m applauding them for doing so :clap:t3: :clap:t3:!!
But this is my thoughts and opinions on this topic and thought I’d share/offer my 2 cents anyways!! :man_shrugging:t2:

This is why we support vpns. There is more i can say based on my info and findings but i wont. For now paid apps will not work properly with vpns so we will have to deal with it. You can still get content other ways with vpns.

1 Like

Have to agree w/@TP-Dracoo …split tunnel paid apps. You currently have one of the top rated vpn’s available, and odds are, if you switch to another, it will have some quirk also. I’ve found the best solution is to find a work-around w/what is available (also, I like the challenge)! jmo…

1 Like

Strangely, Puffin browser no longer appears in Amazon appstore (or was it never there? I used to have it but forgot where I got it). Anyway, I tried to install the Puffin TV browser apk and yes, youtube.com works even if Surfshark VPN is running. However, it seems like youtube works because it ignores my VPN connection. For example, I connected to a US server from my Surfshark VPN. Then from puffin browser, I tried to load the sling.tv website. I got the error page saying that sling.tv is only available inside the US. So there you go…

1 Like