Background not working on my firestick

The background app is not working, out of date but I can not update it. Do you have any instructions to get a app for my firestick. I did download and tried to update it but I dont seem to get it.

Like, the Background Apps and Processes List App?

I tried the background list, it downloads, installs but it keeps saying it is out of date.

If it is the app I mentioned above, it is available in the Play Store and the Appstore. Did you install it with a different apk from another site?

I keeps downloading the legacy one which is no longer supported

I’m looking on my Firestick right now. There are two versions of the app in the App Store. The Legacy one and the other one that says “Made for FireTV and Fire Tablets”. Use that second one.

going to look right now, you on firestick?

I only see legacy on my firestick screen

Use the one highlighted. The next one over says “LEGACY”.


I did pick that one but it says when installed it is version 1.302A6i not the newer vission. It is supposed to be version 2. something

I see what you mean now. I installed it and got this:

The developers must have ditched it. I would recommend using DefSquid to do the force stop/clear cache. Just don’t use it for virus scan lol.

yes, and where do I go from here?

1 Like

I tried the Legacy one too, neither work. As I mentioned, I would use DefSquid. I like it better anyway.
DefSquid APK - How to Install on Firestick/Android for Device Protection - Posts - TROYPOINT Insider

1 Like

Defsquid, never heard of it

1 Like

Yours is slightly different than mine. I have the G6i.
So my version is 1.302G6i

Does your version work? What Fire Device are you trying it on? Max or regular 4k?

Thanks man appreciate your help

1 Like

Is yours working or have you tried it

It’s working on my 4K Max. I just reinstalled it a couple of days ago. I can’t honestly remember where I downloaded it from.

It may still be working on my Max, I was trying it on a regular 4k Firestick. Interesting that it doesn’t work on that but does on the Max. Wonder why.