Amazon update blocks Fire OS 3rd party ADB use

Has anyone else noticed that Fast Task Killer is stopped working as of recent? I use a Firestick 4K.

2 Likes

Working just fine for me.

1 Like

Over the last few days I’ve noticed it has’t been clearing cache as it should. I’ve had it on my 2nd gen Cube for a long time and it worked flawlessly. I cleared the cache on the app and forced closed it with no change in functionality. I guess the next step is to uninstall it and reinstall it to see if that works.

last update was 9-22 v4.04 , so no updates as of late

Let us know if a reinstall works.

I use use the TDUK task killer along with the one click TDUK cache cleaner.

1 Like

I reinstalled after downloading app from TroyPoint. The version of the app is the same as the one I deleted. The end result was no change. Cache doesn’t appear to be clearing or at least there is no obvious change in the listed numbers. My 2nd gen Cube is running perfectly so I’m not going to lose sleep over it. I regularly close all apps with the exception of my VPN and restart the device to clear system cache once a week.

Fast Task Killer Does not appear to be working for me either. I have version 4.0.4. I unisntalled and reinstalled …same thing on all my firesticks 4K max,

1 Like

Please correct me if I am wrong, but I’ve always thought that Fast Task Killer was only to remove stuff that it going on in the background. Getting rid of operations and stuff that is not necessary. Hence “Task Killer” name.

This is from a post back 2021…"This is a quick way to close apps running in the background and free up processing power and available RAM Memory. "

Or go here, Fast Task Killer - How to Install on Firestick to Close Unwanted Apps

2 Likes

I now use TDUK’s App Killer and Cache Cleaner. Thay are faster and more convenient.

TDUK APP Killer - Apps on Google Play

TDUK APP Cache Cleaner - Apps on Google Play

Amazon App Store has the FS versions available, also.

6 Likes

Tech doctor uk app killer not working after recent Amazon update 2/17/2024 when I press “connect to this device via ADB” it says “Connection Failed” I tried uninstalling it and reinstalling it that doesn’t work are there any solutions

2 Likes

This is also happening on one of my Firesticks

TDUK has just discussed this. Latest Firestick update has blocked ADB on certain Firesticks.

2 Likes

Here is the link

4 Likes

Wow this is huge as so many different apps rely on this, not to mention making modifications to the device OS or enabling some advanced features. This will break so many apps and give app devs a real headache. Thanks for noticing this and to @Geejay for providing the link.

3 Likes

It’s not unusual for device updates to break root. On phones, it was always a seesaw scenario.

That’s why many rooted devices would reject updates.

Just one more reason to ditch firestick. I switched to an android streaming device a while ago and no more amazon interference. Life is good. Also, best 20 bucks I ever spent. Became a Patron!

5 Likes

Walmart has the solution for the fire stick nightmare and it only costs $20👌

8 Likes

Is there a possible fix for this? Perhaps Amazon messed up and they will fix it? YEAH RIGHT…JK

In fact there is,and you can even purchase the fix right from Amazon lol

https://www.amazon.com/s?k=android+tv+box&crid=1AS4XG9SBWDDZ&sprefix=android%2Caps%2C138&ref=nb_sb_ss_ts-doa-p_7_7