Walmart Onn streaming device not functioning properly

I purchased the Walmart Onn streaming device and followed the Troypoint tutorial. I downloaded Active launcher and wolf launcher. Now i am having a problem accessing many of the functions. I also get not get back to settings to remove any of the apps or do do a hard reset on the device to start again. I called Onn customer service and they could not help me. Does anyone know how to to do a hard reset on the device or to get back to settings because it will not open up. From there I may able to remove apps from the Troypoint toolbox. Thanks Brent Rubin

1 Like

I had mine up and running, but my daughter uninstalled Wolf Launcher, now all I get is a blank screen. If you unplug device, press little button on front of box (next to LED), keep it pressed in and hold in while plugging back in. That may help your issue, but I need a factory reset I think. Hope that helps you. :peace_symbol:

I did that and the screen came up to reset. Unfortunately could not move the cursor down with the remote. I repaired remote and it still would not work to move the screen to the appropriate area to perform a hard reset.

Someone else did this by connecting the Onn to their computer and using the computer to navigate and select in the screen.

I had to connect device to my computer

1 Like

I cannot connect my ONN device to my computer. It will recognize it but will not open up.

Unless I’m missing something you plug all the power in as you usially do, then plug the hdmi cable into your computer. Don’t quote me on that but I think that’s all you do. Then press and hold that little button when it’s booting up.

I’m having the same issue active and wolf launcher . I can hit the nextflix button and go there but the Home Screen is just blank. I have tried unplugging it pushing the little button but nothing works. If you hold the button down as you plug back in, I can get to that menu but can’t use the remote to navigate it. Let me know if you figure it out.

I was extremely excited to read about the new Onn Box. Especially after watching Troy’s first impressions and how to super charge videos, I ordered my own the day he announced it was available for shipping. Yesterday, a dark, damp rainy Saturday, I spent a good 7-8 hours swapping out my Firestick 4K Max with the Onn. Most everything Troy described in his review and tutorial proved accurate. The box was very responsive, the Google TV OS was much better than Firestick’s bloated and ad dominated OS. But, I ran into my first critical fail when installing and trying to use Wolf Launcher with Launch Manager. That launcher (which works flawlessly on my 4K Max) bombed on the Onn Box. It produced a non-working screen which rendered the Onn Box inoperable. I followed Troy’s installation video exactly, but after hours of painstaking downloads, installation and configurations, I had to perform a factory reset. However, I could not even get to system settings, and pressing the reset button while powering on the device did not work. It brought up the screen to factory reset, but there was no way I could select the correct option to reset (there were three options requiring you to scroll down to select reset, but no way to do that). After much sweating and swearing I tried Google voice command “Open Settings”, and almost cried with relief when lo and behold, the settings menu appeared and I did a factory reset. THEN, I went through the entire process again, without installing Wolf Launcher. So, I installed the basics, attached and formatted a USB drive as internal storage, Nord VPN, and lastly Kodi and various add-ons. Finally, I did a test drive and streamed a movie. It would not play. It was 4K, around 10 gig file size, and while it did start (and looked beautiful), when I paused it and started it again, it buffered, jittered, froze and finally crashed. I immediately thought it might be a network issue, ran the speed test (BTW, the Analiti Speed Test app no longer appears on the Troypoint Toolbox so I used a Kodi speed test add-on), and was shocked to find my download speed was HALF of what I got on the Firestick. This was using the same VPN settings and network settings, but the results were abysmal. I was so angry and discouraged at this point that I swapped back my Firestick, tested my download speed (it was back up to around 70 Mbps with the VPN engaged), streamed the same movie and it worked flawlessly. So, why the failure? My guess is that it has to do with the reduced RAM and the weaker processing chip used by the Onn. Perhaps its WiFi chip is also subpar. But those are only guesses. Whatever the reason(s), the Firestick is back and the Onn Box is headed back to Walmart. I was so upset because I had such high hopes that I could end my toxic relationship with Amazon’s Firestick which is becoming increasingly more locked down, but the Onn Box is not the victorious usurper I had hoped it would be. I wonder if Troy’s initial impressions of the Onn Box may change as he spends more time using it. For now, anyone want a “like-new” Onn Box?


Genius idea about telling Google to open settings. I just re-screwed my onn box up (I previously corrected via laptop), tried your way and it worked! Great job on figuring it out! If you’re serious about ditching the Onn box, let me know

1 Like

If anyone encounters black screen issue after trying to set up wolf launcher when that happened to me and a few others a couple days ago discovered Google Assistant still worked. Simply press Google assistant on the remote and say “settings” . Google Assistant will then open up settings. Force stop both wolf launcher and the launch manager, I cleared the cache also for both set wolf launcher back to being my launcher and it opened up just fine after that.

1 Like

Thanks for the information. Worked like a charm. Had to reset everything up again without the launching apps.

Google Assistant only works with Internet. For some reason my wifi was dropped. I did get back in after cycling power, but I needed to re-enter my wifi credentials.

Mines going back too. When I try to turn on a VPN it immediately crashes.The second try yields a blank screen and freezes the whole box. Have to unplug to bring it back to life. Tried with 3 different VPNs. Also couldn’t add a playlist to TiviMate. It would keep crashing.

Maybe I just got a bad one.

You have a little time in your return window, wait for people to discover fixes and perhaps give onn time to put out their first update. But for 20 bucks and the fact they’re sold out across the country I would never even consider returning one.

1 Like

Sounds like you may have gotten a bad one. I did all the things you did including playlists in Tivimate and everything works flawlessly. Caveat: people scared me away from installing Wolf and Launch Manager. I’ll just deal with the super busy home screen for now.

I was able to reinstall google voice and then went back to locked main menu and used google voice to access settings. From there I did a hard reset and reloaded all the apps I needed. Did not want to deal with wolf and launch manager again.

1 Like

I had my Onn 4k streaming box go black screen. I tried to reset remote because I thought that was my problem. So I pressed and held reset button on Onn box while plugging in and continued to hold down reset button until I saw screen prompting me to restart or reset box. Without remote you can then quick press reset button to scroll through the list Once you get to reset to factory settings press and hold reset button until the next prompt. Then select and finally I was able to reset factory settings. I hope this helps someone because I was going crazy trying to find any information on this myself.


1 Like