VPN Kill Switch

Hey all! I just wiped/refreshed my 4K firestick and have been loading just a few things that I actually use.

That all went well except when I tried to install the “VPN Kill Switch” and I get a "Error: URL needs authorization. This is not supported" message when I try to download it with Downloader. I rechecked that I did used the correct address from the Troypoint tutorial but no go.

I’ve most likely overlooked something of course. I will go back and try downloading it again just for sanity sake. I’ve gotten addicted to watching that green dot flashing off and on. (I probably will need to seek help for that :slight_smile: )


Hello and welcome to our community!

Take a look here: Workaround

And here: Alternative

I hope those guides help for killswitch. You can also look into split tunnel and vpn safety dot

1 Like

Hello Dracoo,

Thank you for the quick reply!
I actually did perform a search here before posting and found and looked at the Workaround. I didn’t seem to fit my situation as the Kill Switch was working fine just before I nuked my stick.

The second link, that you graciously supplied, was the one that I used post-nuke. That’s was the tutorial that wouldn’t download the app in Downloader.

Thank you, again for your help.


Try to clear all app data from the Downloader and clean cache.

Next make sure to install from unknown sources is on.

Try again.

1 Like

If it was VPN safety Dot you could not download you can get it direct from Troypoint Rapid App Installer. Or Try Unlinked.

1 Like

Ok, we are good now. My flashing green dot has arrived.

So I tried clearing everything, data and cache in Downloader and that didn’t change things. So I deleted Downloader and reinstalled it. It still didn’t like “troypoint.com/vpndot”. So on to the next step.

I loaded the Troypoint rapid App Installer. Bingo!! It worked and now I have my green dot. And with the Installer I can put in Analiti so I can check how IPVanish is working based on which server is cranking out better.

Thank you all for your help! It is very much appreciated. And above all, THANK YOU,TROY!
I DO appreciate all that you have done for us folks struggling along.

I’m still mystified why using Downloader didn’t want to work for this app. I have used it several times in the past with no issues. Maybe my karma needs some work.


it’s also available in the google play store…

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.