Universal Remote for Nvidia Shield,Voice Search,Air Mouse,for Android TV Box and Media Player

Ive always been on the lookout for the perfect remote… and many do most but I have never found one that does all…comprende :cowboy_hat_face:

Was searching for a nvidea type (because my shield does most…but not all)…get…ok.
Found this one…at a great price, looked good, said it does all :skull:…oh my, could it be true :partying_face: … I bought 2 great remotes at a bargain or 2 great paper weights.
They arrive, the instructions were so small my reading glasses were futile…
So I installed the batteries(not included), plugged in the dongle…long pressed the power button to sync…and done. Everything just worked, voice, cursor, mute, home, vol up/down, fast forward/reverse, back, menu and a delete button? (under power button is a delete button…I cant figure what its for but I will map it something. Basically everything except a keyboard but I really wasnt in need of that as I have one if needed. Everything works out of the box.
Amazon.com: Universal Remote for Nvidia Shield,Voice Search,Air Mouse,for Android TV Box and Media Player : Electronics


That looks like a WeChip G20. They get rebadged under a lot of different names. They’re far cheaper on AliExpress than Amazon or eBay.
Most of the WeChip remotes are decent. I’ve got 3 or 4 different BT remotes of theirs.

I use the 4K Maxx remote on my shield pro. It does everything except the voice text.

I have several wechip remotes including the g20, however this one does it all except keyboard. All functions work and very stable connection.

I do really like the voice typing…for instance in stremio search, click the microphone …say movie name and boom it goes straight to all movies with that name.

Yeah I have to use the shield pro remote for voice typing.

I’ve not had great luck with IR remotes connecting to my Shield Pro. But I just order this one.

Try as I may, I could not get the ONN universal remote to pair using to two methods outlined in the instructions.

I bought the Alexa Pro voice remote since it was bluetooth. It paired ok but it would turn on my TV and Shield without any input from me so I would have to pull a battery to get it to stop. It would also change to the Shield when I was using my Cube. The power off button didn’t work and Alexa doesn’t speak Google Assistant, so the voice commands were useless.

so far i’m happy with this remote. My wechip remote would randomly turn on the cursor even tho I never touched it etc… just unstable. So far this one is behaving.

1 Like

I have had good luck with the Rii android keyboard remote (with usb dongle) compatibility on all my devices, including Nvidia Shield. You can get one from Amazon for around $15.

They dropped the price to $13.xx just after I bought mine. The crooks!

Ok, so as usual for me. I cannot, for the life of me, get this thing to connect with the Shield Pro.
Step 1) Dongle plugged in > Pressing power button until LED goes from fast flashing to slow flash.
Step 2) Press power button> aim the IR transmitter at the remote > success when the LED lights.

What am I missing?

all I did was place or hold the remote near the dongle pressing the on button for about 5-10 seconds. The remote must pair with the dongle.

Not sure. I just popped in 2 batteries, connected the usb dongle and it was connected.

Thank you guys, for the replies. It appears that plug & play is not working in my case.
I tried the remote almost right against the dongle and pressing the until the LED went out, more than a dozen times. I think that the next step is to launch that remote at the nearest wall at this point. Maybe there is a chance that I got a dud.

check within android settings for usb options. Often you need to enable it or change service on it., or try other ports. If I remember correctly the shield has these settings. Currently using my am8…as my player and although it has multiple usb options, it was plug and play.

Have you gone into Remotes and accessories and turned on the stuff you need?

Here’s what I’ve got.

look into usb options


try swapping the usb ports on the back of device

Thank you, Ron, for the suggestion. I’ve tried that and it didn’t work.