Troypoint Rapid Installer problems

While loading Troypoint Rapid Installer I am able to it but when I try to access the app I get the following message: No ask download link found, check your internet connection and try again. I have a very good connection and I am using the following link:TROYPOINT Rapid App Installer. Please help, I love Rapid Installer it works so seamlessly.
OK still having the same issue, please help!

1 Like

Hello @jrferry25 I would suggest completely uninstalling the app from your device and try again. If you get that message again, try restarting your device. Unplug for a few minutes and then plug back in. Please report back if still not working.


OK, I updated the fire stick software to the version suggested. I then uninstalled both downloader and troy point rapid installer and then reloaded them. I still got the same error message outlined in the first email-No apk download link found, check your internet connection and try again. HELP!

@jrferry25 if you don’t see the “Allow” prompt when installing Downloader, it means that you may be using an older Fire TV Stick or the Fire OS on it hasn’t received all of the updates. Go into Fire TV Settings / My Fire TV or Device / About / Check for Updates. If there are updates available, install them. Keep going through the process until all updates have been installed. My Fire TV Stick 4K is currently on Fire OS My 2nd Generation Firestick is currently on You will see the version you are on as well in the “About” section where you check for updates.


Jack, use downloader to install the rapid app by using not the https it’s already in the downloafe r link.

1 Like

When I go into Downloader to download Rapid Installer, it takes me to a website instead of downloading. I typed but the download link doesn’t come up.

I found it on the website with this silly Fire Stick but it’s certainly not easy.

Hello @LonnGooch the install url changed about 6 months ago. It is

Thanks for getting back to me. I will make a note of it for the future.

1 Like

This updated URL does not work for me I’ve tried it twice over the last two weeks I’ve uninstalled and reinstalled downloader and still once again it will not allow me to install rapid installer are you able to provide a different link or a tip on how I can fix my current problem thank you

open the “Downloader” app, type in the following>
Enter, follow on screen prompts, keep your fingers crossed.

1 Like

yes I did that numerous times keeps coming up with the same error about using HTTPS instead

never had a problem on my Nvidia shield but this is a new fire stick lite

And you’re entering that URL in "Downloader “?
don’t enter either http”// or https:// just what I posted. The downloader will auto add it. Shouldn’t matter but this is an odd issue.

yes absolutely did it numerous times last weekend and this weekend it is very very weird I agree

Very. Try going into settings>apps>manage installed apps> click on downloader, click force stop, clear data and clear cache. Then try one last time. The other thing to try is a “power cycle” Remove the stick from the HDMI port unplug the power wait for a couple of minutes then plug ghe power back into yhe stick and plug the stick back into the HDMI(arc) port. Make sure you are using “house” power and not a USB port on the tv. Then retry. Wish I was there with you to see what’s going on. If you have time, while waiting, you could also power cycle your router/modem. The power cycling may clear a “stuck” IO state resulting in site connection issues.

tried all that no go rapid installer just doesn’t like my new FS lite :joy::joy: thanks for your help


Did you turn on the developer options for the downloader?

developer options for fire stick has been turned on how do I turn on developer options for downloader?

When you use the downloader it will pop up asking for permission and it will bring you to the screen to turn it on as long as dev options are on on the firestick.

Every app will ask for this.

permissions for downloader was on so I turned it off I then turned it back on I then restarted fire stick lite I then opened up downloader and typed in the following…

and the same error message keeps coming up asking me to try http or https at the start of the url