Troypoint Rapid App Installer


I hope someone can help with this. I have installed the latest rapid app installer on my Android tv box. However, it won’t download any of the apps. I just get the continuing spinning circle. After about 30 seconds It then tells me that it’s taking too long to download and asks whether I want to cancel or wait.

Is anyone else experiencing this issue?



Did you try to rebut your TV box, sometimes that helps…

Yes tried that. Also deleted and reinstalled. Just can’t work out what the problem might be!

Hello @Glaws07 I would love to work with you on this as I have never been able to replicate this problem. Can you please try the following one at a time and let me know if any of these work?

  1. Unplug your router and cable modem from power for 10 minutes and then plug back in and try again.

  2. If #1 doesn’t work, make sure that your VPN is off when trying to download through Rapid App Installer. Or, try changing the server you are connecting to through the VPN.

  3. If that doesn’t work, please tell me which Android Box you are using and I will look into that.

Your help is much appreciated as I would like to get this problem fixed as it comes up from time to time.

Thank you!!


Hi Troy

Still no do I’m afraid. I’m not using a vpn at the moment. My box is a Minix Neo U1


Can you please tell me what your Internet speed is when testing with the speed test tool inside the TROYPOINT app?

Hi Troy

Download is 32Mbs upload 7Mbps

Your cable company is blocking you, use a vpn.

1 Like

Nope, tried that still won’t download anything!

I have the same problem. Download 30mbs. With a Maxytec 5G + box.


@Glaws07 @dbelk Thank you for your help with this problem. I’ve went back to my developer with the information that you’ve provided regarding your equipment and hopefully we can figure this out. As I said earlier, I’ve never been able to replicate this problem on my end. We originally thought that some VPNs were blocking access to the download links so we told people to disable their VPN when downloading/installing through the Rapid App Installer and that cleared up the problem for many. So, I would say to try deactivating your VPN once again or try activating it if you aren’t currently as your ISP may also be blocking access. I will get back to you all once I hear back from our dev on this.

Thanks Troy

I will be going away to our holiday home next week where I have the same type of set up. I’ll let you know how that goes.

1 Like

Thanks Troy tried with VPN & without results are the same.

1 Like

Hi Troy

I am currently in Cyprus, using a Minix Neo U9 box with 30mbps download speed. Tried with and without VPN. Still not able to download anything from your app (latest version)

Thanks for your patience @Glaws07 @dbelk My developer is currently pushing out update 4.2.0 for the TROYPOINT app. If you want to do a clean install, you can uninstall your existing app and then open Downloader and type in to install the new release. It appears that Android 5.1 was seeing this spinning wheel problem and the developer has fixed the problem. The app will only support Android 5.1 and higher. Android 5.1 was released in 2014 so a five year window should be plenty for most people. Please try to the new update and if that doesn’t work, please get back to me with the version of Android that is loaded onto your device and I will dive deeper into this problem. We use Android emulators to diagnose these problems and sometimes that isn’t as good as an actual device so your help is much appreciated. Thank you guys!!


Hi Troy

It’s now working for me, at least here in Cyprus. I see no reason why it won’t when I get back to the UK. Thanks for all your help with this issue.

1 Like

@Glaws07 Thanks for your reply and glad that it is now working!!

how do i download rapid app installer? doesnot work

Substitute tpapp in place of ta. I had the same issue and that fixed it for me.

it works so how did you figure it out?

1 Like