Trouble with The Crew Repository

I cannot get the Crew Add On for Kodi. I follow all the installation guidelines, and her as far as “Click install from repository”, and then “Choose The Crew”. But the Crew repository is not listed in the Repository list. I’ve done this 4 times and same every time.Any suggestions?

1 Like


Follow this.

You must follow this. Works perfectly.

Make sure there isn’t any spelling mistakes. It does work I have used this.

1 Like

Thanks. I was extra careful with spelling, that isn’t my problem

1 Like


I don’t see what els it could be. Did you make sure to allow it to install from unknown sources?

I have installed this about 5 times on so many devises over the years and this is the first I’m hearing of it.

You only get it in the repository after you install from zip and see the install complete come up.

File Manager > Add Source (don’t forget the / at the end)
Add-ons > Install from zip
Add-ons > Install from repository > The Crew Repo > Video add-ons > The Crew

1 Like

I have The Crew on Shield (2017) and Firestick 4k. Both devices running Kodi 19.1 and I also use Real Debrid and Trakt. So, pretty much the same set-up on both devices. I noticed a couple of weeks ago that The Crew on Shield would not pull up the IPTV sub-menu. The “working” pop-up appears but then disappears; will pull up the sub-menu for sports, but when I try click on, for example, MotoGP, again the “working” pop-up appears then disappears. All other categories work as they should. Only the above mentioned two categories do not.
Both features on my Firestick 4k work and work well.
I’ve uninstalled/reinstalled/set-up The Crew on Shield but it hasn’t solved the problem.
And yes it’s the same path for this add-on.

I’ve used the Slamious build…and they have The Crew.
I have deleted a few of the add-ons. Not all of them work all that well.
I only use The Crew for some movies…and watching college football games…they have had the most streams that cover my favorite team. Better coverage than my IPTV service come to think of it.

It sometimes takes me a couple of tries to install these add-ons. If you’re doing everything correctly, just keep at it (maybe the next day).

This topic was automatically closed after 30 days. New replies are no longer allowed.

Just tried to re-install my Kodi addons and The Crew repo appears to be empty(?)
Anybody having any luck installing? all working

Already have it installed and is working.

Interesting… tried it on 2 sticks this afternoon. Reload the repo from [], when I try to open it to install it in Kodi, there’s nothing there.

1 Like

maybe there updating not sure if there is another source

That’s what I’m hoping.

Looks like thats the case. After i loaded up the Diggz build i went to recently updated… sure enough the Crew Repo was updated to 0.3.5.

I guess just give it some time.

Im trying to reinstall the crew on kodi. When i get to the part where you click “install from zip file”, after i click on that, on the next page, when i click on crew, nothing pops up like before. No repository. Just a little folder with an arrow on it a 2 dots. Please advise and thanks

Search Is Your Friend...!

Yes, that’s what I’m seeing. I guess the repository is down (updating or dead).