The Promise not working

Oath quit working about a week ago for me. I installed Magic Dragon and it works,but I don’t like how it works. Today 4/30/22 I tried to install Oath clone The Promise.When I go to install from zip file it is blank. No place to click on. I double checked everything & all is correct. I even tried with ipvanish disconnected nothing helped. I have been using a fire stick or fire tv box for over 6 years & been using Troypoint for over 5 years. I have no idea what to do to make it install. Any suggestions? I do not install builds just 2 or 3 addons.


The ‘empty’ folder is usually a sign that you haven’t completed the zip file download successfully. Try again and wait for the pop up and then install via repository :+1:

1 Like

You misunderstand the problem. When I go to install from zip file " The Crew, Magic Dragon, sd card, external storage,net work file system,root file system,repo,windows network (smb) Zeroconf browser etc."When I click on repo which is what I called the promise there is Nothing to click on to to download.No use to go to install from repository because there was nothing to click onto in install from zip file. It is blank nothing to click.

As mentioned, this could be due to a corrupt download. Start over fresh and try again.

Tried it more than 4 times. tried restarting 2 times, nothing there

I also tried adding The Promise this morning and had the same problem. Multiple tries but nothing ever showed. Also had a problem loading Exodus and Covenant. They would only give me the Repo Addon. Would not show the Video Addon so no way to add either one. The only one that I did get to work for me was Fido. It worked fine to addon Fido K19. I’ve been using Kodi for years and never had this much trouble before. I’m not wasting anymore time on the ones that would not work. Too many others available that do work.

I’ve tried promise twice Miki, same problem

1 Like

Try from the main site and see.

Also how do you delete the two I have in zip file that don’t work


I think you long press on the zip and it should pop up some choices.

This is what I used Troy’s instructions. Zip file blank

1 Like

Yep long press in file manager thanx. Have no idea why it won’t bring up zip file

Won’t bring up the repo

1 Like


Well still working but if you want replacement check out this list from TP with the best Kodi Add-ons.
Best Kodi Add-ons

1 Like

I just read it earlier today that why I tried promise. Guess I’ll try another that works with debrid. Any recommendations. I’m replacing oath

I uHacker0x00

OP ·[3 days ago]

Just pushed a new fix for ThePromise … Reinstall new version 2.0.0.

I reinstalled ThePromise on kodi. i installed, new version of ThePromise, version 2.0.0http: // repository.Hacker0x00-install. installed from zio file, installed from repository, Hacker0x00-Repository,video addons, install Thepromise, OPEN, tools, resolver url settings, activated premiumize, activated real-debrid, activaated trakt.

tv shows now works perfectly for me. shows load, episodes load, streams load, episodes play.

i was using Fen as my go to in kodi, because i liked the number of streams fen found for a movie or tv show. also i have a sonos surround sound system, arc, 2 subwoofers, 2 rear speakers. the streams in fen told me the sound i could expect to hear from the streams, like 2.0, or 5.1, or true atmos, 7.1. Your streams in ThePromise do the same for me.

i really like using ThePromise, so far, and will be using ThePromise now, as my goto source for playing movies and tv shows in kodi.


1 Like


I think you already know that in addition to The Oath, Venom and Fen add-ons are also down.

If any problem with firestick check the storage

1 Like

Yes oath was my go to if couldn’t find on crew. Still works but won’t be updates thx


You’re welcome hope this solved your problem.

Did you ever manage to get “the promise” installed? Just curious. tx