Syncler Providers Failing

I have trying to install the Syncler Provider for Kronos all day. I have the right codes I believe but every time I hit done, I get the message that the file failed to download.

It’s driving me nuts, this is when I really need the Troypoint RAI. Is anyone else having this issue?

Yes, im having same issue.
Syncler must be down.

If thats the error you get then it may be down.


Im back up and running :grin:

Syncler’s not down, just finished watching 2 movies.

I am not having issue with syncler, I cant get it to successfully download the kronos provider. Every time I hit done after the app says to hit done it gives me a message failed to download the file. I am following the directions and have the correct url for the github source.

I am frustrated…I have done this on 4 other devices and even downloaded today syncler and did a provider install pc. It just wont work on a fire cube new 3rd gen!

Thank you. I am having a problem on my new fire cube gen 3

if you go to settings and provision and go to my repository and install Ljrano and express package
basically you just need one source to be honest Ljrano gets updated that’s the one i use and works great

sdd, You are probably hitting “Done” too soon. Follow the instructions below.


  1. First, go to the Downloader App and type in 883704 to get the Syncler App.
  1. Now go to the settings on the Syncler App and scroll down until you see “Provider Packages” and click on that. Utilize copy, add this link into that box on your phone, IPad or computer after step #4:
  1. Click on install Kosmos.
  1. Open this link on your computer or phone:

Package installer | Syncler

  1. On your TV, there should be a code on the #2 bullet point on the screen. Write that EXACT code on YOUR screen into the box on your computer/phone.
  1. Hit the Next button after you enter the code. *** Do not hit the done button on your TV.
  1. On the next box in that same window, it should ask for a URL.
  1. Then press Done on your computer, then press Done on your TV.

You will notice that you have 2 Syncler Apps on your TV.

One is an installer app and the other it for activating Syncler to watch movies. *** Delete the Syncler Installer App.

Now activate your Real-Debrid Account on Syncler and turn on your VPN and watch all the best movies around. *** Enjoy!!!


Thank you. I have tried everything everyone suggested, nothing allowed me to add Kronos. I get the message “failed to download the installation file” or "data and package are malformed. I have uninstalled everything and did a fresh install, still no joy. I think since this is the new Firecube 3rd gen something just isn’t making all the pieces go together.

Can anyone point me to the provider app like the one that was on the Troypoint Rapid App Installer.

I about ready to just return the 2 I bought to Amazon.

Thanks to all thas have provided me with suggestions.

Sounds like you are trying to install paid providers into kosmos which wont work.

If you dont have syncler plus then you cant install those only kosmos with the free kosmos provider.

That’s I wait until all issues have been straightened out before buying some new streaming device because with all those new features comes twice as many errors and problems especially Amazon and for the price should’ve got Nvidia shield pro. Only useful streaming devices from Amazon are their TVs

1 Like

I pm’ed you the link for that installer several hours ago.

Each to his own I guess but I have used most models of Firesticks for several years with very few problems.

1 Like

If I can be so bold, do you really need syncler? Now don’t get me wrong, it is an excellent app and for some, very useful. I don’t use it, or like it, and for someone without some experience on streaming devices it may be a tad daunting to get right. So my suggestion might be to simply forget syncler, for the time being, and focus on getting the Cube set up and learn how to use it and where things are, like settings, and then once you’ve gotten a few things done successfully then move on to a setup like syncler and any of it’s depenencies. Just a suggestion.
Happy New Year. gl2u.

1 Like

I agree with Miki if you don’t know how to use your device and fully understand it syncler is not a place to start. Now I use syncler and also stremio with my shield and other devices I have been working with them for quite awhile and understand how to use them. Get aquatinted with yours and then enjoy what ever you want and if you need help along the way this is the place to get it. Happy New Year :v::sunglasses::confetti_ball:

1 Like

Thank you. I am very familar with Fire Cube and how they work. I have 6 devices from gen 1, 2 and now a gen 3.

I am sure it is the device, perhaps it has some glitch with syncler. I am sure my procedure is right, I installed it on my win 10 pc this afternoon, works like a dream. That is why I suspect the device.

Happy New Year!

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.