Subtitles in Cinema

I am wondering if anyone can help me, I can never get my subtitles to work in the Cinema app anymore. I clean out my cash I keep my fire stick cleanly, but nothing seems to work. The message shows up that they are loading and there are choices to pick from but once I choose, they never show up. I rarely see subtitles anymore

Not every link has subtitles. You can try realdebrid and see if you have any better luck.

Hello @rosielee72 you can also try importing subtitles into MX Player. See this video - How to Use OpenSubtitles With the Most Popular Streaming APKs

Thanks so much for the info. I do use Real-debrid and I’m the past nearly every single thing I watched had them. Appreciate your input

1 Like

Thanks! I’ll sure try it!!

1 Like

I have realdebrid and still get the same problem in not getting subtitles.
Which is bad considering the high number of Korean and Chinese movies out there.

I also am having trouble with the lack of subtitles with Cinema. I thought it was just me but from the comments, I am not alone. Although I am using real debrid, the problem persists and can only it seems be corrected by constantly trying different streams until I find one that works properly. Another problem with Cinema lately is the wrong movie being shown when choosing from the streams available for a totally different movie. I had that last night when trying to watch a movie and the first 5 streams I chose played a totally different movie. A real bummer.

Yea I don’t think it’s a Real-debrid problem, but a Cinema one. The link below does work, but you have to go thru the steps for every episode to get subtitles. It’s worked every time tho

When using cinemahd load your rd link, top right corner should see a box beside hq and the heart. Click that should see English subtitles, if they are available and it will download them.

Yes but they don’t work now

@rosielee72

Try using a different link. It’s possible subtitles weren’t added.

Thanks for your response :blush:. I have, they just won’t come up 90% of the time.

Did you turn on close captioning?

Go to “Accessibility.” Navigate to “Closed Captions” on the list. Toggle the “Closed Captions” switch on. Go back to your video by pressing the “Home” button on your Fire TV remote

Also make sure it turned on in the video player too.

Thanks, yea I’ve done all that, in Cinema and the Firestick settings. Appreciate the input!

1 Like

@rosielee72

I can’t reproduce this problem you are having. I can get it working on kodi syncler and cinema with the same links on each.

I’m truly sorry I can’t help you. It sounds like a user error but something is being missed.

Hopefully someone can chime in.

I’m sorry I can’t help you. I am just about to ditch Cinema, my problem is that the streams does not match the movie. It gets frustrating.
I need to look up into something else.

I appreciate all your comments! Oddly enough, since I’ve reinstalled MX player, they’re working mostly, even tho it’s not my choice of player in the Cinema app ( I use their player because it’s less trouble). Maybe that was the problem all along, who knew? Thanks again!

@rosielee72

Mxplayer is a perfered player. That might have been the answer all along.

Glad it’s working.

I don’t have problems with Cinema, per say, but I rely on subtitles, especially if there’s strong accents such as in Outlander. I will say, reinstalling MX player fixed the problem, even tho I use the default Cinema app. I hope you find something you like!