Storage drive, Firestick 4K Max not working

Firestick support can’t figure out why most downloaded (non-firestick supported) apps won’t transfer to thumb drive. Firestick show thumbdrive icon for Kodi, but thumb drive essentially blank.
Selecting Kodi Icon from main screen most often fails to load Kodi on first/second attempt.
Tried everything even format thumbdrive and delete and reload firestick- no success.
Without fee, I help folks with firestick. Previous models doing well, but 4K Max on multiple Firesticks not functioning. Thanks, John

1 Like

Not sure what’s going wrong. It really is the easiest stick to add storage to. Otg cable or otg hub, plug in usb drive format to fat32 and either internal, which is for apps, or external if you want recording. Now transferring 3rd party non amazon store sourced apps doesn’t mean they can be loaded onto the USB Drive. The app developer has to code that into the app in order to be able to move it from the stick, to the usb drive or visa-versa. Also not all usb drives are created equal. I use Sandisk 3.0 16GB drives. Even then with 25 apps loaded onto it, there is not a lot of space used up. The app, even if it’s on the USB Drive, will still kerp a bit of Data on the stick. Now Kodi is resource intensive and really should be kept on your stick as data transfer speeds may not be the best. Data transfer speeds are faster between an app, and the stick, when the app is on the stick, resulting in less errors or problems. So I keep my main apps like Stremio and TiViMate on the stick for best performance.

1 Like

What is the storage capacity of your thumb drive? To work properly thumb drives need to be formatted to FAT32. Drives bigger than 32gb are typically formatted to exFAT or NTFS you would need to convert to FAT32 using the following link: Ridgecrop Consultants Ltd

The Max will format to fat 32 for you and I believe the max capacity is 128GB.


Please review this for all firestick issues and guides, if the following hasn’t worked feel free to ask.

This should resolve most to all issues.

For whatever reason, I’ve had the same issue with 19.4 on our (nonmax)4k, a 2nd gen FS & an ONN android box, whether KOdi was on expanded/adoptable storaage or not. I just uninstalled and reinstalled Kodi when it’s happened.
Lately, on a lark, I installed TP 19.4 Fork instead on both the ONN & 4K and so far I haven’t had a problem at all.

This topic was automatically closed after 7 days. New replies are no longer allowed.