Several apps not working on Android TV box

I have a new EASYTONE Q Plus Android Box with 4GB RAM 64GB ROM Quad-core H6, running Android 9.0. Several apps, such as BeeTV, Chrome, Cinema, FilmPlus, and Play Store don’t work. A splash screen comes up, then back to the Apps screen.

However, many applications do work, such as Downloader, Firefox, IPvanish, SD Maid, Troypoint and Unlinked.

I Have searched the internet for solutions, as well as this board. I have cleared Cache and Data, restarted the box, Unplugged HDMI and power, and no improvement.

It seems the next step is a reset to factory defaults.

Any other suggestions before I do that?

hmmm, well I could see google blocking certain apps but the play store is strange. Has SDmaid made a sucessfull run?

Yes, ran SD maid and deleted several files. Also, have tried with IPvanish running and without

1 Like

Sounds as if you have done the right thing. One thing and you might have already done it but make sure sdmaid has all permissions for proper access. Often people will just run it out of the box without setting it up correctly. Other than that its either a google, virus or something not on my radar. I have never seen the box you have so it could be related there as well.


Run defsquid app and disable google playprotect.

SD maid permission is set to Storage

defsquid screen displays briefly but disappears before I can do anything with it. I can’t find any place to disable google play protect.

In that TP tutorial above security is located in device prefs. But as a note on my mecool box its located in apps at the bottom.

Thanks! While I was looking for play protect I came across that Verify Apps and disabled it on speculation. I just pulled the power plug and powered back up. Defsquid does the same, come up briefly but disappears before I can do anything

Since the Android11 update the “Verify Apps” button no longer exists on a Nvidia, or at least I can’t find it.

Man these coders are really dropping the ball on these updates.


So, I reset to factory defaults and when the system came back up the first thing I tried was Chrome and Play Store. They didn’t work. I installed IPvanish and got that working, then turned off Verify apps. Force stop on Chrome and Play store and cleared Cache and Data. They still don’t work. Installed Defsquid, doesn’t work. Set the permission on SD Maid to storage, scanned and ran. Tried Chrome and Play Store, still don’t work. But most things work, the important ones anyway.

This topic was automatically closed after 7 days. New replies are no longer allowed.