Problems running Netflix on Onn device

I have installed the Onn device on my tv and expanded the memory. Everything seems to be working fine except Netflix. When I run Netflix on the Onn it appears to open normally and run until I try to actually play a video. I can click on a program and it goes to the play screen as it should, but when I push on play it will show that the video is loading but it will not fully install and begin playing. I have the Onn installed on the same tv with my firestick 4k. the Firestick plays Netflix without any problems or delays. Both my firestick 4k and Onn boxes are running with surfshark vpn. Any ideas on what is wrong?

Bypass the vpn for netflix. Vpns are not required or actually allowed although you might find a server to sneak through.


Hello, welcome to the TROYPOINT Insider. Please read the rules and regulations prior to posting another topic. Thank you.

Please use our search function regarding this further.

Also this topic/issue/problem/ or common thing as been discussed a lot and there is many topics on this, please use our search regarding this further. Making the same topics on info that’s already posted is against our rules. Old topics are available to post as they are not locked, our search would bring this up. Thank you for understanding.

I tried that but it made no difference. I only have this problem with the Onn deivice. My firestick runs netflix without any problem.

I did not find this issue when I did a search. Sorry if i missed something.

Try turning the kill switch off temporarily and force stop Surfshark. Also clear cache and force stop Netflix app. Then reopen Netflix again and test.

If it works this way, it will work bypassing it. Then turn SS back on, kill switch back on, bypass Netflix. Clear cache on Netflix app, force stop Netflix, reopen.

1 Like

Thanks very much for the response. This did help, but I need to force stop Netflix each time I start the app.

Very Strange. I was going to say check the storage in settings and make sure the app is running from true internal device storage and not the added memory. But then realized you have the official Netflix and the button on the remote. Worth checking anyway. I just tried Netflix on my new ONN device and it works great.