Subtitles Won't Download

No longer able to dl subtitles on The Crew or Seren. Keep getting "Become VIP member to get subtitles - > I go to the site and to get VIP and they want $. I already signed up for open but now no longer works. Anyone else seeing this? Thanks.

1 Like

I don’t use Kodi. But they sent out this info a few months ago.

I use Stremio and syncler and so far no issues with my existing membership.

Your link to is the incorrect link.

I haven’t upgraded to VIP.

My link is to open but this editor keeps putting a space after “open”, so my link is NOT incorrect! I can go to and login without a problem.

Ok. I wasn’t being awkward. When i click on your subtitles org link in your original post, it brings up a site for sale.

A couple of months back opensubtitles sent out notice they were switching domains. It was from .org to .com .
Give this a try. Great option.


Thanks Miki, I’ll give it a try. I did follow another suggestion and installed Stremio and subtitles work on it. Funny that I didn’t get that notice from since I’ve been registered for quite a while. So for the link you posted, do I click on it with my computer? And then how do I activate it on my FireStick? Thanks again.


BTW, Happy New Year!

It’s an addon in Kodi. I am sorry but I don’t use Kodi. Go to that link and read the info and there should be guidance there on loading it.
Tx for the Happy New Year. Same to you and your family.
I just checked. That link has instructions as well as screen shots.

Thanks Miki.


1 Like

Up until just a few days ago 12/26/2023 I was operating with the A4kSubtitles with no issues. Since then I keep getting a popup that states `A4kSubtitles OpenSubtitles Authentification Failed.

I have accounts with both the OPenSubtitles (.org & .com) and are aware they switched to “.com”. I have no issues using them independently and was curious why then the Authentification failed?

Is there a problem with A4k that anyone is aware of. I visited theri website (GitHub) and cannot find any statements concerning issues with their addon.

I am partially deaf and rely on my Subs.

By the way. The reason I liked A4kSubs is because they always offered up useable Subtitles… OpenSubs does not stand up well on its own and addicted simply doesn’t produce many if any Subs.
I’ve spent the last 4 days trying to resolve this to no luck on my own.

Any help would be awesome.

Device: FireCube 4k
Kodi 20.1 & 20.2

I saw the same message the other day but it went away after 30 seconds or so and my movie played with subs. I dont remember what addon i was using.

I tried Crew just now and it played without fault and even had a language option which i tested and it worked. I tried with a different movie and saw the message again but the sub options downloaded and played with the movie.

If it matters I am using a Build. Not sure if that makes a difference. I also always have subtitles option enabled.

Any other free alternatives?

Upon a little more research, the build i use has a4k as their default sub provider. I dont remember if i ever signed up for either a4k or opensub in the past i think it was always part of the build. I could be wrong about that.

a4k is working well for me right now.

Many addons usually automatically give me the subs since I have it enabled. Asgard, Umbrella and Coalition all do IIRC. The Crew not always.

1 Like

The GitHub source I posted is free open source with exact install instructions.

Steps to install a4kSubtitles:

Go to the KODI File manager.
Click on Add source.
The path for the source is
(Optional) Name it a4kSubtitles-repo.
Head to Addons.
Select Install from zip file.
When it asks for the location select a4kSubtitles-repo and install
Go back to Addons and select Install from repository
Select the a4kSubtitles menu item


I’m using a Kodi 20.1 skin with a Twilight addon, Trakt & Real Debrid & CoocoJoe Scrapers with an OpenWizard/GUIWizard for maintnance-cleaner.
Haven’t used a build in many years. Was working great until the 12/26.
Signed in to GitHub/OpenSubtitles.
Tried searching everywhere. Did reach out to GitHub A4kSubtitles.

Thank you.

Thank you Miki.
I have the a4kSubs loaded and have signed in to opensubs as are requested. Still getting an Authentication fail.

Go to the site using the link I provided. Read through it all, there are pics and everything to show you the exact steps. It’s open source so no idea why it’s not working for you.

1 Like

I uninstalled Kodi 20.1 and loaded 19.5 to troubleshoot, nothing worked or loaded in that skin. I reverted back to 20.1 and reinstalled everything and are still getting the Authentication fail.
I did shut off my VPN thinking it had some compatibility issues but that too made no difference.
I might get one Subtitle in OpenSubs, but they are never synced or don’t work. Its useless on its own.

I switched to my Firestick 4k HD from my Firecube 4k Hd and have the same issue there as well.
So, I don’t know, it might be the Amazon Fire Devices. I uninstalled a4kSubs and reinstalled to no effect.
My subs in Syncler & WYD are doing great. I use my Kodi skin because of the convienance and especially for the Movie Database which is spectacular when searching for movies and actors.

Sorry I never use Kodi so can’t help. Don’t know why you’re having issues.

1 Like