MECOOL KM6 Deluxe Surfshark Crashing

My KM6s seem to crash Surfshark after booting up from “suspend” mode. SS doesnt do that with my Max or Shield. Seems like my only option has been to reboot the KM6 each time. Any ideas, or is anyone having the same issue?

*After reconnected it works great just dont want to restart each time.

did you try re-installing ss? I would remove it run a clean up on the box and then grab a new copy >>>>

If suspend mode is sleep mode…then I’ve never had a problem coming out of sleep mode w/SS on.

I went through and installed most updated version on all 4 of my main boxes through the TP App. I suppose it wouldnt hurt to reinstall on both KM6s and see what happens.

1 Like

I believe that is what you would call it. In the box settings you can set the power button to “suspend”, “shutdown” or " restart". I like suspend because when the power button is hit again it will just come right up and we can continue to use it. When i hop into SS at that point i get a message that it crashed and do i want to send into SS diagnostic team or something to that effect.

Copy…I’ll look for that & try to recreate the scenario & get back to ya’ :cowboy_hat_face:

1 Like

Much appreciated. If I get that message again I’ll take a picture of it and attach it here.


OK…mine is already set for suspend…but I can’t recall ever having a problem w/SS when waking the box back up.

Hey @TXRon You ever have this problem w/yours?

1 Like

The most strange thing when it happens, i reconnect VPN and my speeds go from like 80-90 MBPS to 10-15 MBPS. Once i restart box, works like a champ.

I just tried both after about an hour wait and of course they didnt do it haha. Unfortunately it is happening most on the KM6 in the bedroom my wife uses most. Welp, i’ll be in the doghouse again! :grimacing:

Doghouse = :see_no_evil: I shut my box down nightly & on the very rare occasion when I hit the on button in the am it may take some extra time to wake up…but I’m that way too, so I let it slide :roll_eyes:

Other than that, it’s pretty responsive…I do reboot it & my router probably more than I need to…but hey…I’m kind of a fuss budget with keeping the memories cleaned out.

I am going to try an expirement on them. Going to uninstall Safety Dot and Reinstall SS. I’ll keep an eye on this and let you know. Like I said, i use sleep/suspend mode on all my boxes and the Shield and Max haven’t done it once. I’ll keep you in the loop.

1 Like

my vpn is on my router. I use ss app on my phone only when im out of the house.

How do you all have your SS settings configurated in the SS app? Do you use Auto-connect? Could the “no borders” setting cause more harm than good? What about the “use small packets”?

That’s right…sorry, my CRS has been active lately :roll_eyes:

1 Like

Also, just FYI, one of my FireTV 4k sticks had me update the Surfshark app from (in RAI) to Wonder what goodies they fixed…hmmmm…

Also lol…i figured out if you scroll down to the version number in the bottom left in the SS app, click it 5 times, it prompts you to enter “mobile mode”. Doubt you would want to on TV, but does let you access setting like “invisible by LAN” and “Rotating IP”.

1 Like

New one to me…but I tried it & cancelled it. Went to Troy’s RAI & got the latest version you mentioned…can’t see anything different yet…but then again, I’m about as observant as a rock. You notice anything?

1 Like

So far I have updated it on a 4K and thats it. It had a note up in the top right of the SS app that said something like you are using an outdated version and updates by clicking it. Odd. Maybe it’s coming soon to everyone. RAI still has the .7.

1 Like

No…just updated the .7 I got from there to .8…he must have it linked into SS website download.

1 Like

Haha no way! :partying_face: :+1:

Way…he was updated to latest version the other day too…& when you mentioned your firestick had an update I dashed over to the RAI & clicked on it & boom…there it was. I read a post by Troy the other day where he stated he tries to link to official sites when possible…or something to that effect.

Anyway…got some stuff I have to get after so…good chattin’ with ya…catch ya on the flip side :cowboy_hat_face:

1 Like