M3U URL / Tivimate

I hope it is okay if I ask this. If not please delete. I am trying a new IPTV service, but am having trouble getting the M3U url that they gave me to process. It said input email, input password in that url, but spits out an error on Tivimate. Their instructions say Tivimate works, but I am getting super frustrated. Their solution is for me to use their garbage app (my username and password work in their app) for live tv. I will not do that. I love Tivimate. Anyone else ever have an issue like this? Any tips on how to get it working?


Ask them for an Xtream code…


Are you sure they gave you an m3u or m3u8? With adding a login it’s usually done with xtream codes.


Pang you’re fast. :laughing: :bullettrain_front:


What’s weird is…most all of the services have xtream codes these days…entering the m3u’s for the stream & the epg I thought were long gone.


I’m not sure Pang. Many are going with m3u8. With most players though you are correct. Only makes sense to me to use xtream codes. Thankfully TiViMate allows for both options.


Yea, that is why I am confused. I have never used the m3u8 url.

1 Like

M3U is simply a collection of “channel feeds”. An m3u8 is a collection of channel feeds but also has the embedded xml EPG. Xtream codes usually contain login name and password along with a server url and port number. Then once logged in you have access to the service you paid for and should not only have the playlist but the EPG as well. Clear as mud?
So often with an m3u you have to add the url for the EPG seperately while m3u8 has it embedded and adds it automatically. Oh and I forgot, just to add another dimension the playlist EPG XML file may have a url address that ends in .nz which indicates a “compressed” file. :tv: :eyes:


Your last sentence cleared that mud right up to…silt. :crazy_face: :joy:

@AMD237 R U sure there isn’t an xtream code buried somewhere in the email they sent? Like Miki said…they generally end in a 4/5 digit port #…& are waaaaay easier to deal with.


I will have to look again, but I don’t think so. I have had 3 different support people that i have chatted with, and not one of them was even close to helpful. It was just something i wanted to try for a month to see if it is an upgrade for me, but sure doesnt seem promising lol.

I used to have a rule…no Xtream code…then cya later :wave: I’m too dang old to try & get 50 characters in a row right…I’m a copy/paste kinda’ guy & never figured out an “easy” way to get that url from the email on my computer to my Tivimate…so I feel yer :rage: :triumph:

1 Like

I have tried putting that long thing in dozens of times since last night. If they cant make it easier on me, then heck with em. Plus they want me to use their app over Tivimate. No sirree Bob.


Move on to a different provider if you cant use tivimate. Not much more we can do here. Unless you want to use there app.


Disappointing, as I expected a lot more from one of Troy’s top rated.

A lot of these providers figure they have more control and want you to use their app, its getting more common but when they do I usually pass on by to the next. I do the same with ones wanting a mac addy etc.


I.m with you, I’m to old to mess with it.


I’ve read this thread several times over the past few hours and still can’t make sense of it. Its clear tivimate is not accepting your credential input. The exact format, other than its not Xtreme, is unclear.

This is a current m3u I have for a service that works in tivimate.

https://server.xx/m3u/username/password -with a separate EPG url

I have also been given this format from another provider.

M3U: http://provider.xx/get.php?username=xxxxxxxxxx&password=xxxxxxxxxx&output=ts&type=m3u_plus

EPG: http://server.net:80/xmltv.php?username=xxxxxxxxxx&password=xxxxxxxxxx

IF their login is valid, it will work in tivimate. There is also the possibility of user error.

You could also try the login info in their app. In the words of Russel Brand, Stay Free!



Yes that’s the m3u format, here is an example of an xtream code:
Server address

3gHJyCZ p1B6J5


Output format


it’s more than likely user error, I’ve been down this road many a time you have to have it exact.

1 Like

You may be right, but i have tried it dozens of times. You would think a blind squirrel would find an acorn once…lol