Kodi opens to a black/blank screen

I was watching a TV program on Kodi and I put it on pause and when I returned it would not come back on. I relaunched Kodi and got a blank screen. I cleared the cache, but got the same result, blank screen,

Any help is appreciated.

From the Home Screen click on the following, settings, applications, manage installed applications, Kodi, force stop. Back out to Home Screen. Launch Kodi, enjoy!

I forced stopped, cleared cache, restarted Amazon Max Cube, opened my Kodi 20.1 w/c-man build and are getting a frozen screen. three weeks ago had to do another fresh install. Anyone knows what is causing this. Started with the Kodi upgrade.

check space on stick some builds use to much space and cause that sort of problem

Kodi, sometimes, does not play well with ipv6. Try switching over to ipv4 and see if it gets any better. This should be changed at your router.

There could also be a conflict with one of you add-ons. Have you installed one recently then noticed the black screen happening? If so, it may be causing the crash. The youtube addon used to be flaky.

I recently purchased the Amazon Firecube Max. Using the the IPV 4.1v.
My build is simple using Estuary, I only added Fen, A4k Subs, Wizard cleaner. Works and plays beautifully with zero issues with loads of open memory left on my Cube.
My Firestick Max is having the same issues.
Every time I exit the build and open the next day, it freezes when opening the second page of Kodi. This was happening on the Cman build frequently and clearing the cache, relaunching my cube did nothing to rectify the issue. I’m at my wits end.
The only option I see is leaving my Kodi running. It’s 98% of my viewing. I’ve uninstalled five times now having to rebuild my Kodi and have troubled shot everything I could think of that might be an issue and can’t figure it out.

I do have 34 favorites but this was never an issue until I purchased the new Amazon Firestick Max and Firecube Max.

Any help would be most appreciated.


Does the screen freeze on the loading screen of Kodi?

Or does it freeze after you have successfully entered Kodi and are viewing your addons and favorites?

1 Like

Thank you Matteos for responding.
It’s freezing on the loading screen.
I’m using the Kodi 20.2 and adding only Fen, A4kSubtitles, Aerial.
I’m not using any of the builds and are keeping it very simple. It does this regardless of my builds, was using Cman Superman build and it did the same thing.

Just exited and tried to relaunch and it froze on the loading screen.
This is happening on both of my fire devices Cube/Stick Max upon launching.

It didn’t start doing this until I loaded the Fenn Cocojoe scraper…
Both my Fire devices Cube/Stick Max are brand new…


Please take a look at the post I made in another thread.

It’s called “Kodi Stuck in Loading Screen”

I go into more detail on a possible solution to this issue without having to install Kodi fresh.

Based on what you have just shown me, it sounds like you are experiencing the same issue I have had.

1 Like

Thank you…
I just built another quick build and used only the Crew build and it’s launching fine. I’m thinking it has something to do with the Fen Addon/Scraper… IDK.
Will review the post you provided and hope it helps. I really liked the Fen addon and why I resorted to just adding it.

Again, thank you and are going to read over your post. I’ll let you know how it goes…

I found and deleted the file , hahahaha I think. It was there, I canned it and tried to find it in trash to make sure it was there and it wasn’t. But I can’t find it so I’m sure I deleted it. I’ll know when I test close Kodi tonight…

Thank you for the help. It was much appreciated.

Glad you were able to find the file. It can be tricky to locate.

Hopefully this will help with the issue of freezing at the load screen.

1 Like

So far A-OK… I’ll shut it down for the night and will know come tomorrow afternoon if it’ll launch.
Really appreciate the help.
Thank You :+1:t2:

Shut down and relaunched the firebox twice today and everything is launching as it should.
Really appreciate the help, that was going on my 7th rebuild…
Thank you

Happy to help.

Just remember how to find that specific file. Because unless the developers change something, the error will continue to occur.

1 Like

It took some digging around as I had no idea how to search for the file. But I lucked out by enabling Hidden files in the S-File directory, and it was the very first of two files that were shown.
For whatever reason the developers hid the file…
Apparently it’s an issue and thought it might return when doing updates. Both my Stick & Box are launching after being shut down so you were right on top of it.
Thank you, you guys are great.