Kodi and the crew

I have the firestick, not the 4k. I have installed Kodi 19.3 from Troypoint apk installer. I go to add the crew I put in the address. I have checked the typing so many times I have the address memorized by now. Then I put the name I want to call it, then a message pops up unable to connect to server. I have checked my internet connection, I’m getting a very fast download and upload speed.

I have uninstalled Kodi and reinstalled. I’m now at a loss as what to do. When the error message comes up it asks if I want to include the name in the list.

I’m rather new to this, so…what am I doing wrong. I have clicked the button to load unknown source.

1 Like

A couple of thoughts
Make sure you have enough storage on your device to complete the install. Clear cache of your apps and uninstall any unused apps.
What are you naming the package? Try “crew” (without the quote marks)
Then restart your device.


I have done all that, and still get the same message…

Thanks for your rapid reply

It’s possible the crew repo is down right now. But if not, clear the Kodi app data and cache then uninstall. Reinstall again and you’ll be guaranteed to have a fresh copy because you deleted the app data. Idk why you’d download 19.3 instead of 19.4 though. Once you have Kodi installed make sure you allow installation from unknown sources. If you are still getting an error and the repository is still active then you are definitely entering something wrong. Check some other instructional pages and make sure they have the same web address. Pay attention to http vs https. And if there’s a / at the end don’t skip it.


I was not able to make any connects to their servers tonight?

1 Like

I have tried installing the crew for about four days, at different times and always get the same message. I have to have a setting wrong in Kodi or somethng.

Or the past four days

I’ll try it right now with a fork and report back.


Worked fine for me, so you must be doing something wrong. Follow my video for the first run of Kodi.

Kodi First Run Setup

Then enter the source as this EXACTLY!



I followed your video to the letter, checked my spelling three times and still get the unable to connect pop up. I then tried another add on from troypoint and get the same message. I’m using kodi 19.4 I changed the locations on my vpn, even turned it off and I get the same thing. I’m using the 1st gen firestick.

Pulled the two remaining hairs out just now.

Thanks for all the input,

1 Like

Don’t know what to tell you. Idk how determined you are, but doing a factory reset of your device should solve all issues.

Have you tried a complete power down of the stick, unplug it from your HDMI port unplug the power, wait for a few minutes, 2-3, then plug it back into the hdmi port, plug the power back in, being sure you’re plugged directly into house power and not a USB port on the TV, Fire it all up and see if the problem has cleared.

Hi Bill. Make sure that you are entering a colon ( : ) and not a semi colon ( ; ) for the crew address. The keyboard on Kodi does not show the color until you hit the key that turns the keyboard to capitols. I have had this problem several times on account of poor eye sight.

that should be colon not color, I told you I was blind

I have another firestick, although it’s a v1 also. I’ll try that one and see what happens.

thanks again for all you help and great video.

Yep double checked that . I;m practically standing ON a 62 inch tv just to make sure there’s no mistakes.


This I’m going to try, then. if that don’t work try a different firestick


1 Like

Just installed Kodi on my pc. 19.4 64 bit version and followed your set up guide and get the same message on the pc. Now wondering even with a vpn (express) the isp isn’t doing something.

So use a hotspot. If that still fails then you are still doing something wrong.

I did everything in your video and typed in the address correctly.