Kodi & Addons Loading links/Not Playing

I cannot locate any topics that cover this & if I have missed them I am sorry.

I’m using the Kodi-21 version on 2/Onn 4k & 2/Onn 4k Pro boxes using the Estuary Skin with the GUI Wizard, Elementum, Crew, afFenity & OneMoar addons using SurfShark.

I loaded the 2 new Onn 4k Pro’s Friday and they are still working flawlessly. I have also used the same systems & addons in my Onn 4k devices 4 months ago and they too are working excellently.

This evening however, something changed.
Kodi is loading without any issues. The Addons are loading the Sources in each of the Addons in my Estuary build. But none of the Sources/Links are Streaming and are getting no error messages. It simply kicks back to the program I wanted to launch.

This has suddenly happened to all 4 of my Onn 4k’s & 4k Pro devices today.
Some of the Kodi Programing in the 4k Pro devices are showing blank movie posters with just the name of the program listed in the Info-Wall, but not their posters/banners.

I have tried everything to troubleshoot this but now think that it might be my Provider since it’s happening to all my devices simultaneously.

All the other functions and programing on these devices are working without any issues. It is only within Kodi…

Are any of you having the same issue and or is there a remedy, or, am I being throttled by my ISP provider and if so, how can I get around them?!

Any help would be most appreciated.
Jeffrey

Update: Real-Debrid Account Active. Cache Cleared. Device Cleaned & Rebooted with SurfShark deactivated.
Revoked Debrid in each of the addons and when I tried to reauthorize Debrid, I get an Error popup for each of my addons?

I am clueless here!

Are you using a Debrid service? Did it expire and you forgot to renew?

1 Like

Debrid service is good till end of July.
I tried to reauthorize Debrid but get a URL Failure in each of the addons now?
Debrid is up.

Real-Debrid Account Active. Cache Cleared. Device Cleaned & Rebooted with SurfShark deactivated.
Revoked Debrid in each of the addons and when I tried to reauthorize Debrid, I get an Error popup for each of my addons and or a Resolver URL Failure?

All of the RD Sources are showing, but when I select one, it goes through the normal search but then kicks back to the Program I wanted to launch.
No errors or messages.

Was playing great last night, up until today when I tried loading a Tv Show.

By the way… This is happening to the 2 recently loaded Onn 4k Pro devices. One mine, one my dads as well as our 2 Onn 4k devices.

This also happened simultaneously and why I suspect my Provider?
I mean, everything is working great. It is only KODI that is affected.

Yeah it seems suspicious that is happened to all your devices at once. Thats why i thought it was the debrid account.

Not really sure. Hopefully someone can offer some help.

To troubleshoot this. I uninstalled Kodi-grrrrrr…
Now the blasted Downloader isn’t opening to Troys Toolbox nor can I get Kodi to download from the jiosphere browser. A first…
I’ve downloaded Weyd and Syncler from jiosphere and even downloader, not this time.

I’ve been using VPNs since 2015 and just switched to SurfShark early this year.
Its dirty business in that we pay $130 monthly to our Provider and they’ve a monopoly in this area. We’re stuck with them.

None of my Sideloads are loading now… Kodi, S-Tube, Analiti, Jiosphere, and Downloader file.
Syncler, Weyd, Sling, Peacock are loading as are my support apps Surfshark, FX file, Aptoid & Background App and Processes.

You don’t think it’s my Onn devices do you?
Why would my provider or how could my provider throttle those downloads???

I haven’t the slightest idea. Hopefully someone else can help.

I dont know what jiosphere is but you can download kodi directly from the Google playstore.

Something seems amiss since you are having all of these problems at once to all your devices.

1 Like

I appreciate your time. Thank you so much.
Same ole same ole… Sources are available, but just not pulling.

Good night and thank you again for your time.
Jeffrey

I just re-read this and it may be because your ResolveURL addon isnt updated.

My version is 5.1.137

1 Like

My ResolveURL wasn’t even installed???
Never had this issue before.
Did install with the same results.

Also weird is. I always disconnect my VPN when I install Real-Debrid. However, this Onn 4k Pro, I keep getting a Resolve-Failure. When I reconnected my VPN, the Real-Debrid loaded?

Summary: Onn 4k Pro
Ethernet Connection: Hard Wired In.
Analiti: :point_down:66-Mbps :point_up_2:14Mbps
Using the Estuary skin.
Addons: afFenity, Crew, OneMoar, Elementum, Cman
Support Addons: GUI Wizard, CocoJoe-Scrapers, Arial. ResolveURL

Kodi’s functions are loading properly but for the MultiWeather in the Onn 4k Pro.
Dozens of R-D sources are loading & processing.
:point_right:None of the R-D Sources are Streaming.

Solutions: Uninstalled & Reinstalled Kodi 21.0
All Kodi Functions, Movie Posters & R-D Sources are showing after rebuild.
Cleared All Devices Cache’s & rebooted Onn device.
Reinstalled the ResolveURL and updated.

Everything is loading and working as they should and are being given many Real-Debrid sources, but none are playing.
The Sources in Elementum are also not streaming?
13 hrs troubleshooting and I simply cannot find the cause.

If the sources are loading and processing, what could possibly keep them from streaming???

Been following this thread, what a head scratcher. Long shot, are the application settings for Kodi under permissions for files and media set to allow all the time?

2 Likes

Kodi has all the permissions enabled in my Onn 4k Pro.

What puzzles me is that all the Real Debrid Sources are loading. One movie had 57 Sources and I attempted to play 15 of them to see if any of them would load.
All of them went through the processes of loading, but then suddenly kick back to the source/link page.

Then there is :point_right:Elementum.
I’m getting dozens of Sources/Links that are going through the process of loading, but then quickly kicks back to the Source page without any error or fail message…
In Elementum, if a source is broken or unplayable I always get a small popup that says "Unplayable. I’m not seeing that when getting kicked back to the source list/page.

Mine & Dads Onn 4k devices are now streaming Kodi Sources.
However, Kodi isn’t streaming the sources in our Onn 4k Pro. Both suddenly stopped playing Kodi sources Yesterday evening and we’ve had them for a week and were playing great.

It seems this happened when after the Devices Updated???
Both Devices up dated yesterday morning and I first noticed the issue around 3pm.

I don’t know what to make of it.

1 Like

Yes been following as well and this is a head scratcher. The one thing I would recommend is you have the space on the ONN 4K Pro. Maybe try installing the 21 KODI Fork from Troy’s Toolbox and installing a Build and Authorize Real Debrid. and test the various Addons in the Build. My guess is this will work and there is something in your current setup that is not right

3 Likes

@jericho777

Yes. I was just about to suggest this too… i swear🤞.

@MarkxG and I use different builds and they are working. I checked my Onn 4k and Onn 4k pro and my Nvidia. No isses with the build.

1 Like

I had problems with addon elementum, kept causing kodi to close and other issues, when i deleted elementum everything worked better. May be worth a try

2 Likes

All I have installed is elementum with RD and Trakt. No issues for VOD at all.

2 Likes

Yes I know they are working. I was recommending that the OP try that to completely rule out any issues with his ONN Box. and this would prove that there is something not right in his current setup

1 Like

Look at you @Miki . You are now a KODI Pro! Now we need to get @AJS1 to come on over :rofl:

4 Likes