Kodi 20.4 Update Problems

I have a mecool Km6 deluxe, with multiple TP kodi forks. I also use the latest stable release of kodi and update when a newer version comes along. I have not had a problem with the updates until now. I normally use the Tp toolbox in Downloader, and this time was no different. In fact, I just updated to 20.3 several weeks ago. I just updated to the latest stable release ( 20.4). It boots up just fine, but nothing opens when I hit select. This includes add ons settings or even the power button. I forced stopped the app, and rebooted. Same thing. I checked app permissions. Ok there. All the other apps work fine. Any thoughts?

1 Like

I am replying to my own post. I never load up too much on one streaming app, just in case I have issues like this one. So i decided to uninstall and do a fresh install of Kodi 20.4. Low and behold, I had the same issue. Everything was fine with install. Nothing opened. I reinstalled 20.3 and it works perfectly. I refuse to believe that I am the only person this happened to. I have not been on rookie status for some time. Has anyone else had this issue?

I run a build and several Forks as well and usually my Build gets updated with the latest release but don’t sweat needing to be on these minor point releases. 20.4 was not even scheduled and is the last point release before the next major release which is KODI 21 - Omega

updated to 20.4 yesterday no problems all apps working fine

Updated one of my Kodis to 20.4 and keep getting Trakt error on Ezra.

What skin and hardware are you using?

If you’re asking me I was on stock skin and on my Kinstone tablet. I haven’t tried to update on BuzzX5 yet or Formuler.

You are not alone. I had the exact same issue. The select button on my remote had no effect within Kodi 20.4, but worked fine in all other apps. Rolled back to 20.3 and it works fine again. Hope Kodi 21 doesn’t have this problem when it is released.

Have a friend that was running 20.2 using Confluence skin that had remote issues after updating to 20.4
Fortunately had 20.2 backed up. Uninstalled 20.4 and did a fresh 20.2 install from TP Toolbox then restored to his 20.2 backup. All good now.

So I ended up trying different things. There seems to be no obvious reason for this ptoblem. Someone with far more knowledge than myself needs to look into it. That is why I created the post. I tried installing 20.4 alone. I also installed and tried to update to 20.4 from other versions. In all cases, the other versions all work just fine. 20.4 installs and loads up, but nothing happens when I select a menu item…

I am on Google TV (onn.) running Kodi 20.4. I have the same problem, on the Google TV remote the ‘select button’ does not function and the ‘return’ button acts like ‘home’ . The ‘select’ and ‘return’ buttons on my television remote (Samsung) Do work for Kodi 20.4

I have the exact 20.4 problem. I tried to re-load 20.3, but it would not install. I assume I could delete 20.4 and 20.3 would then load, but I would have to reinstall all my apps. You said you “Rolled Back” to 20.3. How did you do that, and were you able to keep the apps?

I asked about “roll back” as well but havent heard of any instructions.

In use a build so i deleted 20.4 and installed 20.3 again and downloaded the build. Just needed to reauthorize RD and trakt.

You can also download troy kodi fork 20.3 for now and wait for instructions on rolling back regular kodi to 20.3. Or they may have a fix soon but who knows.

Just bought my first onn box yesterday for testing. Having the same problem with Kodi 20.4. Uninstalled it and installed 20.3. Problem solved.

2 Likes

Yeah nobody needs to be updating to 20.4 I’ve seen in a few other forums there are known bugs. This was supposed to be the last point release before 21 - Omega which is already in beta release

The problem is for those like us who have already updated to 20.4, it is a big problem. I have a quick fix for the Kodi programmers. Immediately release a Kodi 20.5 version, where the all the code is from 20.3. Maybe that will allow 20.4 to be overwritten. Whatever, they need to fix this NOW.

I haven’t looked in Troy’s Toolbox but I think there is probably still a 20.3 Fork. Just install that then install what Build or Addons you use, AuthorrizeReal Debrid and Trakt (if you use it) and you are good to go

EDIT: there are both 20.2 and 20.3 Forks in the Toolbox. Either will be good

1 Like

I’m not sure if by apps, you mean the addons within Kodi, or apps installed on your device, of which Kodi is one. I “rolled back” to 20.3 by uninstalling 20.4 and installing 20.3. Installing 20.3 directly over 20.4 is not allowed. I then had to reinstall and reconfigure my Kodi build (Diggz Xenon). No other apps on my device were affected.
By using the term “rolled back”, I did not mean to imply that the process was painless. Sorry for any confusion.

I think some of us see the term “Rollback” as keeping your kodi set up intact and reverting back to the older version.

I too deleted and reinstalled kodi/build. But for those that dont use a build they are looking for this Rollback option. The hassle to reinstall and set up kodi again would be a pain i guess.

I’m staying with 20.3. Glad I did. I thought about upgrading to 20.4 but I’ll wait until they find out whats causing these issues.

1 Like