Kodi 19.3 on Xbox, The Crew add-on

I updated kodi on xbox to 19.3 today and now when I try to open The Crew add-on, I get an error and it doesn’t open. Is there anyway I can fix this?

I have tried uninstalling The Crew and reinstalling it, but that didn’t fix it.

I just reset kodi and installed The Crew again and it still doesn’t work. I never had a problem with The Crew until the Kodi 19.3 update


Welcome to our community :raised_hands: :grinning: :grinning: :grinning:

What kind of error are you getting?


It just says “The Crew Error” when I try to open the add-on

Hi @EyeClarke2465
I just updated Kodi to 19.3 (did a fresh install) on my Firestick and installed The Crew. I’m watching the WS now, and my kids just finished watching a movie using Yhe Crew.
So…. um not sure what to think :thinking:

It may have something to do specifically with the Kodi app on Xbox? Are you using Kodi on Xbox or something else?

Oh yeah you said firestick. I’m stupid lol

1 Like

Hi. My xbox updated automatically to 19.3 yesterday and now I’m getting error on The Crew, Venom and The Oath. Could this be due to faults on the xbox version?


I don’t own a Xbox but it still should run kodi, it’s possible the os in the Xbox isn’t compatible with the new version of kodi.

A fresh install following troypoints guide should do it.

Something in your url source is broken and not getting the data.

Try deleting all traces of kodi and try again.

From the looks of things on kodis official twitter page, it seems its a problem for anyone with xbox. Testing was obviously none existent.

Yeah they pushed 19.3 out quickly because 19.2 had so many problems on xbox. It seems all the issues have not been fixed. I would go back to 19.1 for now until they sort it out.

@Jayhawks659 how would I go about this? As the Microsoft store version is 19.3 ? Is there a way to download it via other means?

@Jayhawks659 I really appreciate your help. Thank you. I didn’t think you could download apk files onto xbox though?

I haven’t had a gaming system in a long time. You may be right. Is there a way to sideload applications on xbox?

It looks like you’re going to have to do some research. I just did a quick Google search and it appears that maybe you can do this using developer mode and a web browser from a PC. Might want to look into that. And in the future heed Troypoint’s advice, don’t update unless something isn’t working.

I have no idea. Im know the basics and thats about it tbh

I as well would like to know how to change my Kodi 19.3 back to 19.2. Unlinked only has 19.3. Troypoint points to “stable” which is also 19.3.

I didn’t want to update to 19.3 yet but it auto updated and now I can’t go back. I don’t think there’s a way I can fix it on Xbox so I’ve installed Kodi on my laptop and it works fine on there

1 Like

If you’re feeling adventurous you can try this guide on how to enter developer mode and install applications. I would suggest uninstalling 19.3 from the xbox before downloading the 19.1 installation file on you computer and trying to transfer it using these instructions. But if you can get by with using a laptop or casting from your phone or something until Kodi pushes another update then I would do that. And find a way to disable automatic updates so this doesn’t happen again.