Is NVIDIA Shield still the best?

Ok I have ejected the Samsung SSD and removed it from my Shield Pro. I then inserted a Sandisk USB 3.0 16 GB drive into the port closest to the HDMI port on my Shield Pro. It was immediately recognized and I was provided two options. 1 to configure as removeable storage and then 2 configure as internal storage. So as I want it for recording vids on so I formatted it as removeable storage. The Shield pro gave a warning about all data on the drive would be lost during the formatting process and would I like to proceed. I chose yes and it took about 30 seconds, it then ejected it and then immediately recognized and mounted it. I then checked my storage in the settings and it was listed there as SanDisk USB drive Total space: 16 GB. I backed out of settings and opened X-plore where in the left panel I could see the drive listed as
SanDisk USB Drive
I highlighted it and long pressed my enter key to open the SanDisk USB drive options panel and chose New folder and named it Tivimate. I hit my return button, then scrolled down and highlighted the newly created Tivimate folder and long pressed on it to open the files options panel where I proceeded to create 2 new folders inside the Tivimate folder. One called Backup and the other Recordings. I then backed out of X-plore and opened Tivimate where I now went to Settings>General>Back up data and clicked on it. This then opened my two Storage options 1 Internal shared storage 2 SanDisk USB drive. I scrolled down, highlighted the USB drive and clicked on it. This opened a file tree in the center panel and options on the right, one of which is System picker, I scrolled over and down to highlight and click that. This then opens a Recordings setup panel for me to choose where to record my backup to. I scrolled over to the hamburger icon on the top left and clicked it. I then clicked down once to SanDisk USB Drive and clicked enter. This then opens the SanDisk USB drive folders selection. I click up once and over to highlight the Tivimate folder and I click enter. I click up once to highlight recordings and left once to highlight Backup and click on it. I then click down to ensure the USE THIS FOLDER is highlighted at the bottom and I click enter. A pop up opens giving me the choice to Allow Tivimate to access files in Backup with a message underneath that saying This will let TiviMate access current and future content stored in Backup. I click down once and right once to highlight ALLOW and i click enter, and the backup begins. Takes about 5 seconds and then I get a backup successfully created popup. I then back out of Tivimate, open X-plore, scroll down to the Backup folder and see that there is now 1 folder inside called TiviMate_backup_20240424_210846_v5030.tmb
With todays date below that and showing a size of 16MB
So that’s it folks. The Sandisk worked just fine and I have set up a scheduled recording for tomorrow morning. Easy Peasy.


Let’s see if it records for tomorrow.

Man I’m not sure. I hear what you’re saying and maybe I could do it with my phone but never tried that. But I hear ya, a picture is worth a thousand words. N E Way. Bedtime for this old man. Ttfn.

Hey @MarkxG Yeah when it comes to recording the Shield is acting like that dang Kodi! LOL

It’s not me it’s you… :rofl:

1 Like

Ok first recording done to the Usb SanDisk drive. I wasn’t actually watching it, but it recorded as a TS but did not record the entire 60 minutes, just 52. So now I’m going to use the same VPN server and do the recording of the exact same show on another channel this aft and see if the same thing happens. The 52 minute recording was 1.7GBs in size. Controls worked perfectly for the TiViMate player and I can FF, RW, pause etc. The recording was perfect quality and no issues in the playback. I am going to make one change in the recording and instead of using the MPEG-TS setting in Output format for the playlist I am going to switch to HLS and see what effect, if any, this has on the recording. I’ll report back later.
So there definately is an issue with recording a full hour on the USB Flash drive. This time it did record for 56 minutes. But that is 4 minutes short of the 1 hr scheduled recording. So now I am hoing to set the next recording to 1 hr 5 min and see what happens.
So this recording worked just fine and recorded the full 65 minutes I set it for. I then did another recording and set it for 75 minutes and that worked perfectly. I have one more recording set up for 1 hr and I’ll let ya know if there are any issues.
Well that’s it for me. The USB Drive is not the way to go. Recordings are definately not reliable or consistent. They are all over the place as far as how much they will record. Now that’s using the HLS output. So now I’ve gone back to MPEG-TS as the output as the recordings are recorded as TS and so this may be the issue using HLS. Trying more tonight and scheduling for tomorrow morning.

So that seems to be the answer. Output in the playlists must be MPEG-TS and then scheduled recordings are stable and all is good in the TP universe. I will know more tomorrow if my 3 scheduled recordings work ok on the USB Drive. Just for an update a 1 hr program takes up about 2GBs on the USB drive while the exact same show on my SSD drive takes up just 1GB. So a 16GB USB will only take about 8 hrs of recording, which from my recent experiments isn’t much if you have a weekly schedule.

Ok final post on this. After switching back to MPEG-TS output in the Playlists all recordings to the USB Drive work pefectly. No issues on playback and I tried everything to interfere with the recording, From starting and stopping Tivimate, to opening and running Stremio, SportsFire, Ola, and OnStream and leaving all running in background. A one hour recording took up 2.5 GBs of space :rocket:. That means on a 16 GB drive you could do say 6 to 7 hrs of recording only.


Has anybody ever gotten a bad Shield Pro unit and had to take it back for replacement.?

A Bad Shield? Is that even possible? Blasphemy! I thought the Shield was the Best!


LOL, but I’m serious. Side by side my fire stick is kicking my shield pro’s ass. I took out the flash drive off the Shield Pro and still doesn’t record very good. I get buffering on my shield Pro but not on my fire stick. And they are side by side plugged in the same TV. Same IPTV service. Same VPN.

I now no longer have any issues recording to removeable storage on my 2019 Shield Pro, regardless of the type it is USB Drive or SSD. I can record series to internal or removeable storage and even do backups to either location with ease. Wish I had the skills to make a vid for the how and where of the procedure as once you learn how to do it with X-plore and TiViMate using the system picker it’s pretty easy. Latest TiViMate updates now make recording even more stable. It is a process as it has to be done a specific way, like making sure to “eject” removeable storage “before” removing.

I had a Shield HDMI port die on me outside of warranty. That was the 2017 model so I ended up getting the 2019 Pro. Still have that one.

1 Like

I switched back to MPEG-TS no difference.

1 Like

Ya I should test the Playlist HLS Output format after the latest updates and see if that’s more stable for me as well. So far the MPEG-TS has been working flawlessly for me, so I left it that way. Popped in 4 different SanDisk 16 GB drives and ejected and reinstalled the SSD and tested formatting both to device storage and back to removeable storage and recordings worked perfectly. Tested adding and deleting folders using X-plore and no problem, just have to go back into recordings and change the route to the folders with System Picker and give them permissions. Did find out that every one gets a different name in X-plore when you eject them and put another back in.

If the pathway to the folder was wrong or change they don’t want to record at all not just periodically. Sometimes it records perfectly and sometimes it doesn’t. Plus the buffing, there’s no reason for the shield Pro to buff like it is. That’s part of my problem also which I had 1 years ago when I first got it for my birthday. People thought I was nuts thinking it wasn’t my shield Pro. But I have my fire stick side by side with my show Pro, my fire stick will initiate a channel with absolutely no buffering, The Shield will buffer for several seconds before initiating the channel. I know just weird just straight up weird. I don’t believe I’m doing anything wrong it’s a simple setup. It also could be a very well simple issue with the DNS numbers coupled with the AT&t modem but nobody knows what numbers I should run.

With your experience I can’t see you not knowing what you’re doing. I really think you’re spot on with there being a Shield Pro issue. May be worth contacting Nvidia and explaining your issue. I have known one person that sent their unit back, mail collect, and got a replacement, free. Apparently it was a glitchy connection on the board.

1 Like

Well I bought a brand new Shield Pro from Wally world since it would be easier return than Best buy. It acted just like my shield Pro so I know there’s nothing wrong with mine. The new one buffered worse than my 4K Maxx. So I return the new one and kept my old one. Weird just weird.
I put my IPTV provider playlist in the new Shield and set up just a few channels on favorites to test it. A little bit of work at least I know now that there’s nothing wrong with my shield pro.

Wish to blazes I could put a finger on why you have issues with the Pro as my experience is completely opposite to yours on the exact same device.

So your issue isn’t with the Shield Pro but with your IPTV or ISP, right? Or something else?

Got a little confused but seems its not an Nvidia issue. Its getting late in the East coast lol.

1 Like

I’m going to try another HDMI cable I really don’t think that’s it.
It’s just glitchy, LOL

Good luck.

I cant go back and read over 300 posts to know exactly your issue. Lol

I’d offer help but it would only be guess work and there are qualified people here.

1 Like