How to fix 2 new USB DRIVES

I increased the storage on TWO firesticks following troypoints video. It worked perfectly and the apps showed up with a flash drive icon beside the apps in ‘managed applications’. I made the USB drives both 50/50. Half is storage and the other half is the android operating system and APKs.
The next day when I turned the tv on the firestick was not reading the USB drives. So I had to install all my apps again onto the firestick. Now then…Both of the USB drives were new. When I plug them into my laptop I can access the storage partition but I cannot access the other partition with the Android operating system . My question is how can I get rid of the partition with the OS and Apps on it. Annoying because I did this to two new usb drives.

Hi Westy686,

I’ve run into similar problems.

Did you try viewing the partitions using ES File Explorer or Xplore?

End of the day I had to reformat the drives and start from scratch. Probably your best bet.

When I ran into problems getting the partitions to show properly after using various format utilities I used Rufus here from the Troypoint tutorial here.

Hope this helps.



Firstly, what brand of flash drive did you use? I tried doing this on my parents firestick with a cheaper drive and it was a complete waste of time. It kept getting corrupted when switching between the firestick and PC. So I bought a Sandisk and all the problems went away.

Secondly, the only way to get rid of a partition you can’t access is to wipe the drive and reformat. I like to use command prompt to clean the drive sometimes in case Rufus or whatever other program doesn’t completely erase the partitions.

1 Like

Hi, They were new sandisk drives. Both USB drives worked great with the OTG cable the night I set them up as storage. It was the next day neither worked. I will try rufus but windows does not recognize the 50% partition on both USB drives as they are the android operating system created by troypoints video. Anyway I will try and reformat using Rufus. Thank you for replying.

Yes I have used file explore and I can see the 50% storage and the 50% where the android operating system created by troypoints video. I tried formatting the USB drives on my laptop but…windows does not recognize the partition but I will try Rufus. Thank you for your reply.

Windows won’t recognize the Android system partition, only the partition used as storage. I’m confused on what you are trying to do now. Your first post asked about deleting the system partition. So are you trying to scrap the idea of having a 50/50 drive and just want the whole thing to be external storage now? If that’s the case just re-format the whole drive to FAT32 and pop it in the firestick.

In Windows 10 using command prompt.

Step 1. Connect USB to your PC and press Windows + R keys.

Step 2. Type cmd in the Search box and hit Enter to bring up Command Prompt.

Step 3. Type the following command lines one by one and hit Enter each time:

list disk
select disk + number (Replace 2 with the number of your USB drive.)
list volume
select volume + number (Replace 10 with the volume number of your USB flash drive.)
format fs=ntfs quick (You can also replace NTFS with FAT32 or exFAT.)

1 Like

Sorry to be a pain. I followed Troypoint storage video on two diff sandisk drives for my TWO firesticks. both worked on the night I did it. The next day the storage usb drives were not showing anymore when I turned on my firesticks. So…all I want to do is format USB’s back to original size of one partition (32GB) so I can use them for photos, files, movies etc… Right now they only show as 15GB. I have already used the command prompt with all the directions you sent and as I have said in my other posts it only recognizes the storage partition (15GB). It does not even list the other 15GB. I want to get back the ‘15GB’ that windows does not recognize. I do not know how else to explain this. Maybe it is not possible to get back that 15GB that has the android operating system on it. Anyway don’t waste anymore time on me. Troypoint actually says in his video that only the storage partition will show on a computer as the other is the android operating system and will not be recognized by windows. I will try a different partition software. Even if I can just get the other 15GB back so I can use that space as 2 partitions on the USB. Right now I can only use 15GB of the 32GB.

You can do it. Are you using a Windows PC? I’ll modify my last reply to be more specific for what you want to do. About to drive home but I’ll get back to you soon.

Yes and I have updated to windows 11

Oh… Hopefully the process is still the same lol. I’ll Google first.

Yes it is the same and I have even tried diskmgmt.msc with no luck

I downloaded EaseUS Partition master and it could see the other partition. I formatted it to FAT32. So now I have still have two partitions but can actually use both so I am happy now. I will do this to my other USB. Thanks for your suggestions. By the way have you ever tried to make external storage using troypoints video. Reason I did it is to keep the firestick clean and it may help with buffering etc if apps were saved externally. Thanks again

Brand new Sandisk 3.0 128GB USB not recognized in My Fire TV (Firestick 4K). It does not show up in “My Fire TV” (Storage: External Space: No USB Storage Detected). I have formatted (using Rufus) 3 times. Xplore display does not match the Troypoint video display… Help?! Suggestions?

I made a whole new post about it today covering the different options for formatting USB for firesticks. For removable storage all you have to do is format the whole thing to FAT32 and you should be good to go. When you format it for internal storage is when things get tricky.

What you need to do with yours is actually “clean” the whole disk using command prompt. Forget the part about different volumes.

Here’s that post from earlier.

This article explains it perfectly and the steps are still the same. You want to clean the disk using diskpart.

I have done nothing with partitioning or different volumes. I simply want to be able to record to the USB for occasional TV sports and/or other movies and programs. I simply can’t get the Firestick to recognize the USB (using the Amazon-provided OTG cable).

1 Like

Idk what Amazon provided OTG that would be. But if you follow the article I posted above to clean the disk using diskpart in command prompt and then format the whole drive to FAT32 you should be fine. On the firestick 4K it may not show in the settings but it should show up in Xplore or ES File Explorer.

@westy686 let me know if that worked for you.

1 Like