Getting No Links in Cinema HD

Any help would be appreciated. About 30 hours ago, I am no longer getting real debrid links or in some cases, no links at all on Cinema. Using 2nd gen fire stick that has been working great. Is it a coincidence that this started happening within 2 days of getting a new tv or could there possibly be some way the tv is playing a part? I know that might be a stupid question but I am somewhat tech challenged so please excuse my ignorance. Thanks for any help!

I’ll tell ya flat out, 90% of these questions on here are as a direct result of your Real Debrid subscription having run out. Log onto your account on line and check your status. That’s your starting point.


I appreciate your reply but it doesn’t run out until late March and is active.

Ok tx. That’s a great start. So now I have several suggestions and questions. Have you done a complete clear of Cached Data for the Cinema HD? Have you tried the complete power cycle of your device and TV? Reboot of your Modem? Have you attempted an uninstall and reinstall of Cinema HD and then go into settings to re-authorize your Real Debrid? Have you logged into your account on line and then go to your devices and removed your Firestick and then try opening Cinema And re-athorize RD. Last but not least, if none of the above works for you have you tried installing an older version of Cinema. I apologize for all the work you have to do, but that is the nature of this hobby and without having that device in my hand, I’m afraid the grunt work is all yours to do.


Thank you for all of the suggestions! I have done a few but will complete the list to see if it will resolve.

1 Like

I did notice another issue, with Cinema HD, that I hadn’t known about, and that is, that it may not work, or find sources, if you have an ad blocker running.

I don’t anything other than the firestick stuff that isn’t able to be uninstalled that I am sure run in the background and cinema. I also use IPVanish but lately it won’t stay connected for more than a few minutes at a time. I have no idea why and have been in touch with them but they keep giving me the same answers which do not fix the issue. Unfortunately, my subscription with them renewed in Sept so I am trying to hold on since they don’t refund. I did add the free dot app from troys toolbox but the updated version of IPV has their own so I took that one off. I did not click on the ad blocker on IPVanish for the reason you mentioned.

I ran into the same problem awhile back. Turns out the newest version of Cinema has issues with older versions of IPVanish. Uninstall and reinstall IPVanish from the Amazon App Store (I know, but trust me, it works) set up IPVanish and open Cinema and RD. Should correct the issues you describe.


Thank you but I did just update IPVanish and it is still not staying connected and I am still not getting real debrid links. I also logged out of RD in cinema and logged back in and that didn’t help.

So at this point I have done everything you suggested other than installing an older version of Cinema so hoping that will work. :crossed_fingers:

I have as a back up Cinema HD 2.6.0_,build_109_MOD_09.13.23 installed from " Endless Apps" code 84c4937D on unlinked store.

No intrusive ads or pop ups!

I have just tried it, using my Nord Vpn and numerous movies/ series and both provide AD and RD links. Yep i have both debrid accounts.

I switched from AD to RD because of poor support and just letting my sub expire.

Good luck.


Thanks for the info. I also have Kodi with The Crew add on loaded on my firestick and I went there to see if it loaded links and it did not have any of the provider links that I normally get. It only had one provider with torrent links and none of them work. So I don’t understand why all of a sudden I can’t get links on either app. I haven’t had any problem getting links over the last few months since I started using the stick again. It just doesn’t make any sense to me at all since I can’t say that I completely understand how all of this works. The only links I get on cinema now are ones in white and have the download arrow next to them. I don’t understand why it suddenly changed and what part of the puzzle is broken. Very frustrating.
Well, I just tried to get links for a different show and I get debrid links that also all have the download arrow out beside them. None of those providers ever had that before.

I dont understand what or why you have a download arrow next to the stream.

Have you tried looking in settings in Cinema, to see if Real Debrid is still signed in on the app. Sometimes, it might sign you out.

Doesn’t mean your RD subscription has expired.

But if you are still signed in to RD on the Cinema HD app in settings; suggest you log into Real Debrid and check whether Cinema is included in apps with RD permission.

If not, enter it into the appropriate box.

Then check out your Cinema App. If still no streams. Suggest you log out of RD on your Cinema app. And then log back in and check streams in movie/ series.

Yes, I have already logged out and back in and it didn’t help And RD does work with Cinema.

Then i am stumped. Which version of Cinema HD are you using?

off the wall question, how long have you had your fire stick?? and also have you changed your HDMI socket…

It is a 2nd gen firestick that I got in 2017 and used until 2021 and then didn’t use for about a year and half and just started using again in Sept. When I started using it again I deleted Kodi, Cinema and IPV and reloaded them from Troypoint app and it has worked well. Until 2 days ago Since Sept, it has been used with a couple of tvs. 2 days before all of these issues occurred, I got a new tv so I was wondering if somehow it was causing problems.

Done it all and still no RD on Cinema, Cyberflix or Kodi (FEN and Twilight).

Damn. Well time to use a good free app like Stremio or Kodi then. If none of that worked then It’s time to move on IMHO.


The thing that is the most odd to me is that I get some RD streams on some movies and some tv shows but very few and strangely, not on the really popular shows. So I don’t understand what the issue can be since I don’t really understand what or how each piece of the puzzle does. I don’t know which component is not working properly to be able to try to fix it. Also, I use The Crew add on in Kodi since it is listed as the best on troypoint website. And it seems to be having similar issues as far as links. And as I am typing I am trying to navigate in The Crew and it isn’t working. When I click on New Movies, it doesn’t go anywhere and several other things seem to not be working. Ugh!