Gboard Not Working on NVIDIA SHIELD

My Gboard quit working on my Nvidia Sheild Pro . Tried everything . Cleaned cache , force stop rebooted box . I don’t know how to get it back . Can I get some help please ?

Settings>Keyboard>Manage Keyboards


I know were the keyboard settings are . It’s set to Gboard but it won’t come on . I rebooted the box . Did everything but it will not come on .

Don’t have a Shield but maybe go in to Manage apps and show system apps, make sure the keyboard hasn’t been stopped somehow :thinking:

What kind of remote are you using? Are you using the stock Shield remote or something different?

When you go to settings>keyboard> and then click on Current keyboard, does it at least give you an option for Gboard?

If so, I would try switching to Leanback keyboard, using it for a bit, and then go back and select Gboard again to see if that fixes it.

Go to Settings → System → Keyboard → Current Keyboard and select Gboard.
If Gboard is not present, check that it is installed (Google Play Link)

If that didn’t work, try: Go to Settings → System → Keyboard → Manage Keyboard and uncheck Virtual Remote Keyboard.

Also, check in your Settings> Apps>All Apps>Systems Apps>Gboard> Force Stop> Clear Cache>Permissions>Allow File & Media, Allow Microphone.

If the issue still persists uninstall updates.

Note: If the GBoard app does not appear in your Systems Apps. Then you need to install the GBoard App from the Play Store. (Link Above)

I just tried all your suggestions an deleted all the updates . Still no keyboard . Is their away to reinstall the app ?

I gave you a link for the download. Go to the Google Play Store and download Gboard.

Also, you can try this.

  • Uninstall any recent keyboard update installed from the from the Google Play store.
    1. Open the Google Play store.
    2. Select My apps.
    3. Under Recently Updated select GboardGoogle Keyboard.

I also noticed that in keyboard settings Gboard shows that it is turned on but I dont get the blue dot like I do in the othe keyboard options when turned on . I guess this means its not working .

How many keyboards show up when you click on Current Keyboard?

I went to Google play an it telling me its already installed and I did uninstall all the updates still didn’t work .

First Uninstall Update!

Try Clear Data

On your Home screen hover over to the Search Icon and click in it. Does ANY keyboard show up?

In Settings>Apps>Special App Access>Energy Optimization>Gboard disable

Btw, I disable all optimization for all apps on my streaming devices.

How many keyboards show up when you click on Current Keyboard ?

Tried that no keyboard shows up . Went to Optimization turned it off still no go .


Here is a link for the Leanback Keyboard.

Leanback Keyboard APK (Android App) - Free Download (

I have the leanback Keyboard but I wanted a keyboard to Copy and paste files . I tried some but I couldn’t get a keybooard to use them .

Put or use the Shield TV Remote on your phone, it will let you copy and paste. It’s free.

Have you tried enabling the leanback for a bit and then switch back to GBoard?

Also, install the Nvidi8a Shield TV remote app on your phone or tablet and you can use that to copy and paste stuff.

Shayde Im using a Nvidia Sheild Pro box . How dose it work with a phone ?

Have a nice day!

You put the remote on your Android phone and it controls your Shield via wifi. Many of us here use the Shield remote phone app.