Firestick stopped recognizing usb

Any ideas to solve this. My usb was working fine this morning but now is not being show on my Firestick 4K. I changed the cables but still nothing. The light is on on the usb.

1 Like

Try the old reliable power cycle. Unplug everything completely from power. Wait a few minutes. Put it all back together. Plug everything back in. Fire it up. That should fix it. Oh one note. Sometimes the icon for an app doesn’t emediately load. So I go into manage installed apps, click on the app and start the app. Let it load, click the home button, and it should be loaded.

1 Like

Can you help me with this problem on compaion

Have you installed the companion app? What happened? I need to know what you have done or at what point can’t you do something? Sorry but I don’t know where to start.

Down the bottom of this page you will find instructions for the companion app and registering an account. It has pics for easier understanding.

1 Like

That is the problem i cannot create a account with the app from google store it keep saying user name already used or username is incorrect but the problem is i never put in user name it asks for email and password first to set up account and i have a android cell phone im setting it up with. Thanks

1 Like

Your username is your email address that you used to sign up with.

if you can’t remember your PW just use the “Forgot Password” option and set a new one.

1 Like

To signup where in google or tvmate cause i have not signed up for premium yet

1 Like

Thanks but did not work. I have a number of apps on the usb and all were showing up in manage installed apps and now none of them are showing.

That should have worked. I’m thinking your USB may have died. Do you have another drive you can plug in and see if your stick recognizes it? Is this the older 4k stick? They were a bit awkward for adding storage.

I tried another USB but it is not recognized either. I did an update to and wonder if that did something. Thanks for your help.

There is one thing that may be the problem. Some of the older 4k sticks, which yours is, had issues reading the USB drive when the ADB was turned on. So go into developer options, turn off ADB and then restart everything and see if it comes back.

Turned it off, restarted but still not finding the usb apps. Thanks.

Damn. Sorry. I just lost my USB drive this morning. Had to change my powered USB OTG hub and plug it all in. Took 4 restarts with the ADB off before all the apps loaded into manage installed apps. Mine just started doing this. My current FireTV OS is home version 6410028.1
Not sure if this was after an update.


Sorry it happened to you as well. I’ve restarted about 10 times with ABD off and it still won’t show the usb apps. Maybe the usb is fried.

Sorry about that. Reenable adb and restart one last time and if nothing happens then it could be your USB but not sure.

I had a problem with the USB one time on my 4K maxx. The 4K Maxx recognize it when I try to record on it I get a buffering signal. How the heck can you get a buffering signal on USB… Anyways what I had to do was eject the USB restart the fire stick put the USB back in it and restart the fire stick again then it would recordon it and everything was fine after that. I have a USB stick myself that my fire stick won’t recognize anymore.

I can’t load 2 sticks that i do for friends, both sticks are a good few years old and haven’t been used for quite a while. i have done everything i can think of, looked on you tube done what you said still can’t get it to work. I did see a quick pop saying something wasn’t available because the app is disabled, do you have any idea what it could be. Thanks

1 Like

Old sticks don’t recognize extra storage. That you may be able to use the ADB Shell, but the commands are difficult to type up and enter. Just not worth the frustration in my humble opinion. Firesticks in general don’t do added storage well. Even the Max you either can get external or internal storage, but not both. If recording is for you then something like a 3rd gen Cibe that recognizes NTFS would be better.

1 Like

No not looking for extra storage or anything, just clean the sticks and uninstall application that don’t work anymore.
Never come across this before and been doing sticks for about 10 years or more.
Thanks for your help though it’s much appreciated. I think my friends need new sticks :grin: