Firestick 4K Max Can't stream large files

If this has already been discussed elsewhere, please direct me to the right place… I couldn’t find anything specifically about this.

I’m using a Firestick 4K Max with Stremio, RealDebrid, and Surfshark. I have 1GB AT&T Fiber, which gets me around 400Mbps at the Firestick and about 40Mbps with the VPN running.

I can’t select a stream in Stremio for any content that’s larger than about 8GB, and sometimes not even that. If I do, the Firestick goes haywire immediately… the video playback either stutters or hangs, although the audio sometimes continues to play, often warped, and most buttons on the remote no longer function or it can be minutes for a button press to be recognized. I often have to unplug the Firestick to get it functional again. This is not just an issue of buffering - I know what that looks like.

This is annoying because I have a pretty good setup - an LG OLED TV and Sonos Arc sound system. I can’t select the streams that offer the advanced features that my system supports, like Atmos, because they’re usually much larger - often over 20GB.

Can the Firestick just not support torrents that large? Or is it something else in my setup? I should also mentioned that this also happened with my previous 2 devices - a a FireTV and a Firestick 4K (not the Max) so it’s not that this particular Firestick is ‘bad’.

Sounds to me like you are running close to max memory and storage. I always keep my stick with a minimum 1.5GBs of space free. No Kodi builds, just a fork with one or two builds. I used a maintenance tool wih Kodi, specifically Open Wizard and used the presets for low ram. I never watched greater than 1080p and around 2.5 GBs in size. I have background apps and process list installed as well as Fast Task Killer and made it a habit after a day of streaming to use both before watching a vid on Stremio. Do a search for optimizing Max as there are things you can turn off to help.


Having same issues with the same device. Everything was working good last night. I have plenty of memory so it’s not a memory issue.

I went into Surfshark
and it was telling me to turn off killswitch.
Seems to have solved my problem.

I don’t use killswitch, so that’s not my issue.

I have 1.8GB free so that’s not the issue… well, assuming that should be enough space. I don’t think I have cache turned on… not sure if that makes a difference. I’ve deleted all other APKs since I don’t use them - Stremio works well except for this torrent size limitation. Maybe I should try one of the APKs that doesn’t use torrents to see if it has the same problem…

I guess my point with all this is that I have an exceptional 4K TV and an Atmos sound system, but I can barely take advantage of those features, or not at all, because of whatever limitation I’m hitting. I’m just unclear on what that limitation is.

On my 4k max i usually stream 20gb 1080p files no problem. Im assuming you are trying 4k files? I usually just stick to 20gb as anything over can result in buffering. I only have around 40mb fibre.

20GB files would be awesome. I appear to be limited to 8GB, often less. And yes, I prefer 4K files since I have a 4K TV and the picture really is noticeably better at 4K. I realize I could downgrade to 1080p, but that defeats the entire purpose of buying a high-end system (yeah, I know, First World problems…).

And I noticed you said ‘stream’… my understanding is that Stremio actually uses torrents, not streams, so it functions differently. I’m starting to wonder if that’s my problem - it needs the device to store more data at a time than a stream.

Im using real debrid with torrentio, so cached torrents.

I ran across several other articles/topics that mention that a VPN is technically not necessary with Stremio/Torrentio if you’re using RealDebrid, and I only use RD sources. How risky is that really, though? If I want to watch something in 4K with Atmos sound (or in some cases any 4K content for certain movies/shows), I think the only way that would work for me is to turn off the VPN, which would boost my throughput from 40Mbps to around 400Mbps.

I don’t want to do something that’s going to land me in trouble, but this issue is infuriating considering I paid a lot of money for a fantastic setup and can’t use it to its full extent. The usual response to similar questions is “I never watch anything without a VPN”, and I know that’s the safest route, so there’s no need to reply if that’s all you have to say. I want to know specifically what the risks are with just RD.

You are going to have the same people chime in here and say that RD is safe. Blah blah blah. If you are part of Troypoint and the insider, he is going to recommend you use a VPN for these unverified streams. People think because RD streams are encrypted it is 100% safe, but still doesnt protect your identity. You do what you want, but Troy’s crew should listen to his advice and protect ourselves the best we can.

1 Like

I agree with @AMD237

I’d be more concerned with your vpn reducing your speeds from 400mbps to 40mbps.

I get 115mbps w/o a vpn and 60ish with it. But it will also depends on what speed tester you use. Ookla says i get 20mbps and i know that isnt right because i watch 4k movies with no buffering.

I think @Miki is spot on with using a wizard to modify your Kodi settings. Your buffer size needs to be drastically reduced so you aren’t hitting the limit of your RAM. Usually a lot of those wizards will read your hardware and recommend a setting. But try playing around with them manually and saving your changes to see if it makes a difference. Also, I’m not sure how Stremio works, but with Kodi I set it up to play cached torrents only so they stream directly from the Real Debrid servers without having to temporarily download the whole file on my device. That will eat up your free space very quickly.

Unpopular opinion/reply here but just wanted you to know I’ve been streaming using KODI for 8 years and do not use a VPN. Not telling you what to do just letting you know I have never had any issues


use sticks all the time never had that problem. think problem is elsewhere

“The use of a VPN is totally useless with our service since your IP never shows up during the download process. You are always “behind” our servers. However, if you want to use one, it is possible.”

This was copied from the website of AllDebrid (not Realdebrid). You will find that the VPN question is the first item discussed under FAQs.

1 Like

Real Debrid is the same. You can even login on the website and go to your account settings and set your connection to “secure”.

I just tried watching a 4K movie between my 4K Maxx and my shield pro with stremio. Your biggest limitations you’re 40 Mbps. I have U-verse which is 50 megabytes per second which is like a model t with four flat tires. On my 4K Maxx I could stream up to 12 GB that’s it. Start buffing real bad. On my shield Pro I could stream up to 29 GB and then it would start to buffer. Now this is without Rd because since I never watch anything over 1080 I cut 4k out of my Rd list. These are just torrent files. I believe you’re 40 megabytes per second is the limitation. And since my 4K Maxx cannot handle anything over 12 gigabytes that’s also a limitation. I hope this info helps, you probably need to try it without your VPN to see what happens. But I believe the 4k max still going to be your limitation.

Use another APK, there more than one:)