Downloader not compatible with my amazon fire tablet 10

Hi,my fire tablet 10 has blocked my downloader app ,saying not compatible, also sayingthat version 1.4.4. is for an older version of the fire tablet, and when they recieve an up to date from the developer they will allow it???. Previously dowwnloader app worked for the first year while i was using my tablet.Kind regards,Paddy.

I don’t have a tab 10 but a few months back someone tried what you want and I think the first thing you have to do is install the google playstore and get the downloader from there. You might send a PM to @TXRon as I think he’s done all this.


I just used this guide>>>
Install the Google Play Store on your Amazon Fire Tablet (Updated Nov 2022)


Thanks for your reply.

1 Like

Appreciate your response

Was it blocking you from downloading from the Amazon Appstore and also blocking you from sideloading it from a place like apkpure too?
I have a fairly new (year old) Fire 10 tablet and Downloader version 1.4.1 is working on it. You could just grab that from apkpure if you haven’t tried that route yet.
Here’s the 1.4.1 version if you want to try:

1 Like

Maybe consider yourself lucky. I uninstalled IPVanish from my Fire Tablet 8 last night, and tried to install SurfShark. It bricked the device. I got a constant “fire” logo that has been blinking off and on since. I went to the recovery BIOS screen and tried to reset to factory settings. Deleted the partition after that. Rebooted through BIOS and the blinking logo continues. The code says: E: failed to mount/ cache (invalid argument). Research says you have to be a programmer to even have a shot at fixing this. It’ll make a nice paper weight. Oh well, I needed a new tablet anyway.

1 Like

Your help is much appreciated.Its blocking all 3rd party apks i usually download from the tutorials/downloads section of several youtube sites that supply apks to download to firesticks/Android devices. Regards,Paddy.

Is it blocking you from downloading the apk or blocking you from installing it?

Hi, thanks for your reply, playstore blocking it ,saying""this app is no longer compaatible with this device , contact the developers. “” My device is Amazon fire tablet 10. I have put downloder in by sideloading it but when i try to download 3rd party apps on downloader nothing downloads.Downloader worked when i purchased Amazon tablet but, not recently. Must be Amazon blocking downloader. Kind regards ,Cloughie.

Okay, so you have Downloader installed, but you’re not able to install any 3rd party apps. Have you enabled Apps From Unknown Sources?

Hi,yesi have downloader allowed in , install unknown apps,
problem is, when i go to install apps on downloader
nothing installs, the orange line that runs along starts but does not finish,
tried various 3rd party apps from popular sites but none of them downloads.
Must be Amazon.
Amazon did send pop up saying" this downloader version not compatible with this device
mentioning,they are waiting for new version from developer and when they recieve it they will sort issue.
Thats puzzling because i installed 1.4.1.thanks

Are you trying to download from several different sites and they all fail, or are you just trying to download from one specific place?

Another question, can you not use a browser to download your apps? Is there a particular reason you needed to use Downloader?

Some browsers will not install APKs. Yes they may download them but not start the install. This from their site.
You can use Amazon’s Silk web browser to download these files, but by default, Silk can’t install . apk files.

I don’t have any trouble using Silk browser to download and install apks. I just tested it a minute ago with FilmPlus and upon downloading you get a popup saying this file could be dangerous, but if you click download anyway it downloads to whichever directory you choose. Then just click on the file after it’s done downloading and it installs.

Very odd. Must initiate another process as they state that by default it will download but not install APKs. I use downloader or ES File Explorer. Or maybe you have added or have an active plugin. So some may not be able to use the Silk browser to start an APK. Have a good night Shayde.

1 Like

I don’t know but it works, silky smooth. :wink: Hope you have a pleasant night too Miki. Getting ready to watch a little tv now. :tv:

1 Like

Same here. Ya it may work for you but for many on FireTV it won’t. Thus the Downloader app or a file manager. Back to my series as well. Have fun and enjoy.

Thanks everyone, appreaciate hyour replies. Regards, Cloughie.

1 Like