Download VirusTotal onto Firestick

Downloaded VirusTotal v2.5 from Troy link . It installers ok but won’t launch. When I try it give msg: Error, internet is not available. My internet is connected any working fine. Any solutions or suggestions?


Virus Total 2.5 on Nvidia Android—“No Internet Connection” - APKs - TROYPOINT Insider

1 Like

Hello @teetsjr If using Ethernet unplug and connect through WiFi instead. Or, disable VPN and try again.


That worked - Thanks!

1 Like

Tried both suggestions. And still same issue. Generic android device Minix U22xj max.

Old version from.unlinked stream it all worked just fine.

I just downloaded Virus Total. When I go to scan it tells me that internet is unavailable. My shield is hard wired. What do I do?

I have exactly the same issue on a Minix U22xj max ( generic android) device.

And there is nothing wrong with my internet, using ethernet cable or even wi fi, which i tried out as a fix.

No place to comment or advise Troy on his latest blog on installing Virus Total.

Went to unlinked and found a version on stream it all site, and it works.

Hello @lukgeo , we’ve commented a lot on this. Unplug Ethernet cord and connect WiFi and it will work.

@TROYPOINT . I love this site and all that you do for all.of us. And this is not directed at you.

But why would a dev produce something that only works on wi fi, when we all know that streaming on our devices is far more stable whilst using ethernet cable.

So every time we run a virus scan use WiFi only and/or turn off VPN? Or only to install?

I downloaded the Mouse Toggle App and tried both versions of VirusTotal. I check the box to accept the terms but when I try to scan, I get and error statement saying internet is not available. Any ideas?

That’s two of us, and yes I have disconnected SurfShark, and verified that I had a solid Internet connection. I have also deleted the app and reinstalled it.

Use WiFi not ethernet.

I never seen a benefit of having virus total.

1 Like

Thank for info. Use wifi n install no problem :+1:

1 Like

Hello, I’m assuming this is due to the fact that it was designed for phones and tablets where there is no Ethernet. Still should work but I think there must be something in the code that doesn’t allow for Ethernet because there would never be Ethernet on phones or tablets.

1 Like

@TROYPOINT . Hi Troy. Thanks for that. That would make sense.

I keep getting error, internet not available. I have a firestick 4k os (NS6298/4760) Fire TV Home Version 6470105.1. I’m connected via ethernet I have tuned on and off my VPN powered off and on my firestick and Uninstalled and reinstalled Virus Total all to no avail. Please help

Several topics on this and from what I think Troy said it only works via WiFi, no idea why. So you may have to unplug ethernet, hook up to WiFi and give it a go.

1 Like