Did I get a “bum” 4K Max?

Having changed out all my 3 Firesticks to 4K I only bought ONE of the Max versions. I cannot understand some of results I am getting. For example, as we know there isn’t a lot of space on a Firestick and so I would RELIGIOUSLY clear the cache before I started or ended an app running on the Silk Browser. Now, no matter what I do, even after I clear the cache, it pops back up with “something” well over 150MB even if I didn’t play it. The result is that I have to stop whatever I’m watching, sometimes in as little as 30 minutes, clear the app cache and try to get back where I was in the movie. Is there a switch turned on somewhere or do I need to return this to Amazon as defective. Here’s a photo. Remember I CLEARED all the caches already.

Thanks ed in sc

What app are you using when the data issue occurs

Did you “force stop” apps you’re not using and see if that helps?

Doesn’t matter. I actually attached the wrong photo(s).
In this first one I go to FireTV Player and clear cache which you can see is now “0”
I hit the back button and go back to Fire TV Player and it shows 16.38kb
I know realize those other numbers are the space the app takes up.

Does this make any sense?


After I have cleared cache, back button and return.

Try running the debloat tool from the rapid app installer and see if that fixes your issues.

1 Like

I have similar issues with space being hogged up by apps. I think some of my apps are backing up useless data (VLC and others). How can I keep this from happening? Also, is there a way to delete addons I seldom use from a build? Trying to speed up performance…

I asked which app because there is an anomaly when using tivimate on some fire devices. The quick fix is within tivimate. If you’re asking why apps take up space its because its the stored memory of the app. If you’re asking why is the cache populating after clearing its because that particular app is still running.

Ditch the build and just install the add-ons you use. Just my opinion.

1 Like

Thanks Jay.
No change unfortunately.
Just so everyone knows I’m 67 have worked in IT all my life until I retired to SC last year, so first, I TRULY APPRECIATE YOUR HELP , and it’s worth knowing I “ain’t no kid”.

New Topic Maybe this is an easy fix. Before Silk Browser showed up in my list of managed apps. Now it does not. Advice?

Thank you again for your time and suggestions.
ed in SC

My apologies. I did not mean for my response to appear rude. I don’t use tivimate so it’s a moot point to me.

1 Like

Yes. I have that app which tell you which apps are running. The only thing that is always on is my Nord VPN. Everything has cache cleared and stopped. Yet in mere minutes the cache is starting to fill up again… aaaaaaaaagggggggggggggggggggghhhhhhhhhhh

If you ran the debloat tool it might have disabled the app. You can easily open the tool again and uncheck it to enable it again. Still not sure of an answer to your original question though. Thinking on it.

Thanks for the help. Ran it again unchecked. No difference… :face_with_thermometer:

Hmm, maybe something else in that tool is still preventing it from showing up. Maybe run the tool in reverse to go back to stock and see if it shows back up?

How big is the cache getting on apps that are running in the background after you’ve force closed them and cleared cache already? I feel like the apps are always going to be in some sort of “ready state” and will show a few kilobytes. But are they getting to be a few hundred MB when you haven’t even opened them?

I forgot to ask.
Does Amazon offer any support other than “send it back”?
Thank you all
ed in SC

Idk what to think about that. I’ve never had that message. If it were me I’d do a factory reset and then install apps and use them one at a time for a while to see if there’s a problem app.

Are you streaming things through the silk browser? That might be a problem.

Interesting. Why? Been using it for years without a problem. Which should I use?

Not sure. I haven’t streamed anything that way in a long time. Have you checked to see if that’s the app that builds up the most cache?