Diag mode:boot_completed detected

Recently when I restart my fire stick 4k max
the message “diag mode:reboot_completed detected” briefly appears at the bottom of the tv screen. Does anyone know what this is? If so how do I disable the message.

2 Likes

almost has the sound as if its rooted…but try disabling adb in preferences.

Thanks for your response. I tried what you said and it didn’t work. It’s a brief message and disappears after a few seconds. This is not a big deal since everything seems to be working. I am just curious about what it is. Thanks again for your help.

Ive never seen that message, maybe a diagnostic message used by amazon, no idea maybe @Miki has seen this. Real quick question have you installed any “off label” apps recently?

It appears that you may have started the stick in diagnostic mode, then the system has done a reboot after a restart. This also could be because the hidden developer tools mode was activated and diagnostic mode accessed, and subsequently the stick restarted. Did this just happen one time only?

1 Like

I updated to kodi 20 but I had been using Troypoint 20 fork with no problems. This shows up on the home screen after restart before any apps are accessed. If I find out what it is I’ll post it. Maybe another Amazon glitch. Lol

Did you read my post? Does this happen every time you start your stick? Is this only happening when you start kodi?

1 Like

Every time I start the stick.

Are you using the Monitor Dot (Beta)? If so, the developer said that the message only shows up in Beta until he makes Beta stable.

This was a response to someone else in a different thread that is experiencing a similar issue.

2 Likes

That was it. I had been using previous versions with no issues. I tried turning it off but still had the issue. Uninstalled it and that fixed it. Since I now know what the developer said I reinstalled it. Thanks for your help. I would have never figured it out. I told TXRon I hadn’t added any off lable apps but I didn’t think about this because I had used it before. Thanks again for your help.

2 Likes

When restarting my Firestick, I get the message “Diag mode:boot_completed detected”. Any ideas?
On another note, are you guys (& gals) switching to a different device? If so, what?

i have firestick never get that maybe an app you have causing it

I get it too, but no idea.

Diag mode:boot_completed detected - Streaming Devices / Hardware - TROYPOINT Insider

Thanks for your help

Our KM2, ONN boxes and Shield Pro show it every time they’re started. Only started recently

Very odd as I thought this was an old issues resolved a long time ago. Maybe the old uninstall/reinstall may fix it. Give it a try.

1 Like

What launcher are you using?