Crew not working today

Is anyone else having a problem with Crew? It was working yesterday day. I can open it but I can only watch Porn! lol. Thanks in advance. ACSlater

Ya i having same problem no sports

Just tried it and it works perfect. Now I only use a build that has the Crew only. Nothing else. No sports, nada! Sports come and go unless you want to watch professional handball from Pakistan. Just pulled up a movie, a recent one, and it pulled over 40 1080p sources. I don’t pull 4K because it causes buffering at time and my speed isn’t that good

2 Likes

Watching a TV series on The Crew as I write. Working great!! Hope you get your issue resolved

1 Like

@ACSlater1

Just tested The Crew Add-on, everything works fine, movies tv shows, sports, iptv.

Also Ghost this is another add-on inside The Crew Repository working to.

The best thing to do to get it working is update it. Go to Add-ons> Install from Repositories> Navigat to The Crew Repo> Long press on Ok from your remote> Check for updates.:+1:

3 Likes

@Rampage62

I’m glad to help.
Please you can post the comment here that solved your issue. This will help other users as well. :+1::pray:

1 Like

What matrix said to do worked for me thanks alot

2 Likes

This topic was automatically closed after 7 days. New replies are no longer allowed.