CinemaHD Few RD Links

Hi all! I am having an issue on both Cinema and Cyberlink with few (if any) Real Debrid links being available. This is usually when I’m watching a tv show. I might get a few Zero or Torrent links, and Torrent never works when I select those (just “spins” and never loads). Zero links are usually only HQ options and rarely HD, 720 or 1080.

Could this be my internet provider? (I am running IP Vanish.) I’ve seen a few comments here and there regarding some providers being a bit more challenging when it comes to streaming.

Thanks for any and all suggestions!

I’ve been having the same issue over the past few weeks. Most of the older shows don’t show any links.

Ditto, I’m having the same problem

Type deactivating IPVanish to load real Debrid into Cinema and Cyberlink and then reactivate it.

1 Like

Yes, just now having trouble on my 4k firestick in the living room. I uninstalled all my apps, because nothing was loading on any of them. I even uninstalled ipvanish. Went back to troypoint rapid app installer and installed all the updated apk’s i was using. I linked my real debrid to cinema and cyberflix, and then logged in my ipvanish account and connected to it. I started getting all my real debrids popping up, and actually playing now. Good luck. Hope that helps! Thanks @Anonymous


Delete cinema go to unlock my TV on filelinked
Works a treat

So, I’ve had a couple of issues with Cinema lately! First, after an update (and all of the issues I’ve had with Cinema occur after an update), I wasn’t getting and RD links. I was able to resolve this by going to “Settings” in RD, logging out of RD, and logging back in! Everything went back to normal.

However, last night I had another Cinema update. After that update, it took awhile for Cinema to run, and when it did, the icon for the app wasn’t there! The app worked, however, and when I went to watch a TV show, all of the RD links had the words “need resolve” at the end of the string. When I selected one of them, all I got was the blue swirling circle (and it never left the links screen).

t this point, I uninstalled and reinstalled Cinema, logged back into RD, and everything seemed normal, EXCEPT the RD links still had “need resolve” and would not play. This morning, there was another Cinema update, but it didn’t take care of this issue.

I believe this is a problem with Cinema, as I went to other apps where I’m using RD and they all perform as expected. Or, it could be an issue between Cinema and RD. I’m going to attempt to contact RD and put the question to them (although, from some of the previous posts, my understanding is that their customer service isn’t the best).

If anyone has any solutions/suggestions, I’m all for it! In the meantime, I’ll keep everyone posted as to what I find out!

So, here’s the update…

I contacted RD, who sent a canned response saying that they weren’t responsible for any issues being experienced using a particular apk (okay, I’ll roll with that, for now)

I contacted the folks at Cinema…haven’t gotten a response yet, but it’s only been 20 minutes, so…

After reading a lot of responses here and elsewhere on the forum, here’s what I did, and here’s what I found:

  1. I logged out of RD on Cinema
  2. I exited Cinema and Disconnected IPVanish
  3. I fired up Cinema again and logged into RD

When I picked a program and got the links to the available streams,
a) All of the non-Torrent streams were FINE
b) All of the Torrent streams still had “need resolve” as part of the link

Next, I logged out of Cinema and got back into IPVanish and connected. When I went back into Cinema and tried another program:

  • I ONLY got RD Torrent links (the other RD links did not show up)
  • The Torrent links still had “need resolve”

So now, it appears that if I want to watch an RD stream in Cinema, I need to disconnect IPVanish. Since all of this mess started with the last update for Cinema, I think it’s on them to get it straightened out!

Troy, if you know anyone over there at Cinema, tell them to get busy!!

1 Like

Final update…(sorry, it’s the engineer/problem solver in me that won’t let this go!)

In Cinema settings, you’ll see a line item for “Turn off Resolve Premium Links (Recommended)”. They may recommend it, but I don’t, not at this time! I had the box checked because they recommended it, but found that I got significantly more streams to choose from (especially RD streams) with the box unchecked, even with IPVanish connected!

Hope this all helps!

1 Like

Thanks so much everyone! I tried deleting and reinstalling and that helped a bit. I did make sure to try unchecking the “resolve premium links” option as well. I was able to get a few more RD links! I consider even these few a huge success!

Please keep the suggestions coming in as you find more solutions gang! :slight_smile:

Iansambrook23, I’m not sure what you mean when you stated “go to unlock my tv on filelink.” Is filelink another app? I’d like to try your suggestion.


Keep an eye on your RD expiration date, if it’s past due you’ll experience all the symptoms your having now.


Any updates on this issue? I can’t be the only one not having any links to streams… This is happening on titanium, cinema, morphtv, and teatv. Rd is also active.

Same is happening on Titanium and Ciberflix on my sticks as well. Don’t have IPVanish on so that’s not it. Did an uninstall and reinstall…nothing…

Ok, so i just had very little real debrid links on Cinema. The couple of ones that did show up said “Need Resolve” and won’t play. This was while i had on IPVanish. So i disconnected my IPVanish, and went back to cinema and all the real Debrid were showing up, i mean a lot of them, and that was using the movie “crawl”… i never had this happen when using my IPVanish account, and real debrid… pretty strange. Do you think it matters if i dont use IPVanish account while watching a real debrid link on cinema???

Hbublow, I’m having the same issue even when I have reconnected RD with IP Vanish connected OR disconnected. I am still getting access to a few more RD links after deleting the Cinema app and reinstalling it, but not anything like what I used to get. Still a mystery to me…

So as of right now, i have to have my ipvanish disconnected in order to get any real debrid links to show up on cinema and cyberflix, and for them to play. I wish we could get some answers on why this is all of a sudden happening with IPVanish, and these apps​:thinking::thinking:

I found that after going through the procedure I outlined earlier, and re-establishing the RD links, I was able to exit Cinema, connect IPVanish, and everything was still good in Cinema (except the Torrent streams, which still said “need resolve” and won’t play.

I have experienced Comcast/Xfinity messing with my streams (i.e., lots of buffering) if IPVanish wasn’t connected. But, that was before I had RD.

1 Like

Thank you for your reply. I took my cinema and cyberflix apps off for now and I’m just using the titanium app, with RD account and IPVanish account…

I am having the same problems. when using Cyberflix I get a “no data” trying to watch Big Little Lies. Just updated Cinema and have no icon or anything. Did not work. Went to Exodus Redux in Kodi and have tons of RD sources but they all buffer like crazy…What is happening???