Cinema APK issues

Is anyone having issues with Cinema, by any chance? I’m getting an “Error 503, Having issue with Premium server” when I try play something with Real Debrid. Possibly a bug with the recent update? I’ve tried multiple Real Debrid links and I’m getting the same error on every Real Debrid link.

Never mind on my previous text. My Real Debrid account expired yesterday. Had to make a payment on my account.

3 Likes

I’ve never done that once, more like 2 or 3 times…LOL

2 Likes

I was laughing at myself as well after I thought about it! Lol.

And I thought I was the only one that did that!!! Nothing like that feeling when you’ve spent a hour trying everything possible…and just can’t get a working RD link…then realize what happened. Finally learned to mark my calendar.

I’ve always marked it down on my calendar, but didn’t do it this time. Last night after I payed, I marked it down on my calendar. Just gotta learn from my mistakes. Lol

1 Like

It took me a couple of minutes to figure out that my subscription had expired. Luckily, it didn’t take me an hour to figure it out. Lol

As soon as I sent my first reply, I broke into a sweat, so I quickly opened my calendar,…you know, just to make sure! I’m good for 5 more weeks!

Mine is buffering literally every few seconds! It’s driving me nuts. My speed is great and I use IPVanish, which is supposed to have the best speeds, but not so sure now. I uninstalled and reinstalled from the Troypoint website. My understanding was that was supposed to upgrade with the fixes included in the install. I didn’t fix anything. Same buffering. I’m thinking of going back to Kodi. Anybody else still getting buffering issues from Cinema?

Cinema has been discussed here so much that many are sick of it and switched to good apps like Stremio and Kodi. My suggest, jump ship and start once again, to enjoy streaming. Cinema has had it’s day.

@LadyScot101

It doesnt buffer for me, there something els going on. Id also use something els.

When encountering buffering please take a look here, lots of info.

I went back to cinema when seren started giving me issues. 1 month in and only 1 issue with cinema.

You’re lucky. I never use it anymore and won’t.