Can't Install Kodi Builds

I have a new firestick. I can install kodi thru Downloader no issues. I assume that means in hooked up to the internet. I can’t get any builds (tried 3 different ones checked spelling on each) to load. I get the couldn’t retrieve directory information. I have nord VPN. Tried loading with nord on and off. System info- network shows internet connected. My tv is a fire tv but using a firestick if that makes any difference. I have the other sources turned on the tv, kodi and the firestick. I Have two other older firesticks in the house all working with no issues.
Any thoughts on what I’m doing wrong?

have you enabled unknown sources on stick maybe reinstall kodi i use 20.2 with no problems

I have enabled it on the TV the firestick and in kodi

I just downloaded kodi 20

I also tried kodi 19 just because that’s what my other sticks are using with the same result

what apps are you after

Anything lol I tried superman atomic matrix (kodi 19) misfits nothing loads

ok can you send the urls you are using for them i presume these are builds for kodi i will check them

I have checked them in my phone Brower and I get the files showing up there

ok ile have a look but i never use builds on stick all my apps are stand alone

That’s all I’ve ever done
Link is

ok ile check it for you be about ten mins

Thanks for your help
Greatly appreciated

If you have an address you know works I can try that

hi just checked you are putting in wrong url try this type exactly your using a capital h its all lower case

dont use capital h thats why. the url is correct but all lower case

Don’t think it’s in caps in the kodi add source. I think my phone puts caps on the 1st letter of the 1st word but will check it

i just loaded it all lower case all works

My file source does not have any caps. I loaded this on my older firestick n it works on that one. It’s gotta be dome setting on the newer firestick

so when you type in file it says cannot retrieve directory do you want to keep it

1 Like