Cant connect Surfshark to wired connection

I have 3 wireless connections 2 mecool boxes and 1 PC no issues through SS. The 1 wired connection will not connect. Ive tried removing all antivirus etc still wont connect. This is also a mecool box wired directly from internet. Have no issues with any wireless device.


1 Like

I would first plug a laptop or something else that has an ethernet port on it & double check that proper signal is going thru that particular wired connection…if verified, I’d next try plugging ethernet into device & then restarting both device & router. Check to see if restarts/reconnects fixed the problem.
Let us know… :cowboy_hat_face:

Thank you for the response
Unfortunately ive tried all that. If i switch to wireless it connects instantly on same device. Laptop anything connects no issues. I have a wireless range extender pligged in off this line also for my phone or any of my friends no connection issues.

This is in my back shop/mancave. Its about 500 ft from house. I installed a underground cat cable so i could have solid internet. Theres a spiltter at the shop. 1 line to range ectender a second line directly to mecool box. I watch alot of sporting events w friends family back there i wanted fastest best connection for IPTV. I have over 100-110 speed. Its a solid connection. Have had no issues for the 3 yrs its been installed. My other VPN connected zero issues. I switched to SS for price and speed.

So am i missing a setting in SS?

Thats whats odd…wireless connects…range extender plugged into same line that goes directly to mecool. Makes no sense.

I even tried uninstalling reinstalling app. Same thing. Settings in mecool maybe?

is internet verified on that cable? Have you tried hooking up something other than the mecool to see if its a live connection?

OK…not totally understanding exactly what all you’ve got hooked up…but when I see 500 ft…well, that’s even stretching the limits of RG11 coax cable…so there’s that. Ethernet will degrade even more at that distance, if I read you right & you buried 500 ft of it. To be honest…I also don’t know how you’re getting a wifi signal that far. But…if you have connection & speed right now…I’d call that good myself. :cowboy_hat_face:

Edit: Forgot to mention signal loss from splitter…also, from a quick ethernet distance limit check.

There are a few different versions of ethernet cable, but they all have a maximum distance of 100 meters (328 feet). It should be noted that Cat7 cable has harsher distance limits than Cat5e, Cat6, and Cat6a. Cat7 gets advertised for its 100 Gbps speed, but that will only work for distances up to 15 meters (slightly over 49 feet). Beyond that, it drops to the same 10 Gbps speed of Cat6 and Cat6a (although it still retains its superior 850 Mhz bandwidth).

1 Like

If you haven’t posted a speed test on the wired box without VPN yet, I think that will help.

I answered both your questions already. My speed is anywhere from around 100 to 110. Yes at 500 feet! Its been hooked up and running for 3 years. I dont know how you dont understand whats hooked up. Its a cat cable to my back shop to a splitter. 1 line to range extender the other to mecool box. Thats it. The last VPN worked fine. ANYTHING hooked to it wired works fine. Laptop, tablet, phones anything works wireless. The only thing wont connect wired is surfshark VPN. If i go wireless connects instantly. Which makes no sense because the range extender is hooked in with same connection as mecool box is.

Hey @kres19 The reason I didn’t understand your setup is because ethernet cable goes out of spec at 100 meters…you are 172’ beyond that maximum spec…therefore, I wasn’t sure if your numbers were accurate. And then if any decent signal did make it that length…you said you also split that signal…which would degrade even more. How all this works with your good signal & speeds is beyond me…but good on ya. I guess this is more about why your Surfshark won’t work when wired up. Really not sure what difference wired or wifi makes to a VPN…so I guess I can’t help you on that. My android box is hard wired & SS connects & works fine…either way. There’s nothing I had or have to switch on my box or on the SS app for it to work in either configuration…so I guess I’m stumped too…sorry. GL2U :cowboy_hat_face:

Dont know im for sure no expert. But i have comcast cable 500mbps service to house. My house is about 350 ft from rd. So i lose alot even with a amplified signal from comcast. Im prob around 300-325 at modem. But then drops after router etc… Im getting in house wireless around 90 after SS VPN. I only got about 40-50 with IPvanish. So yea dont ask me how but after splitter im gettin over 100+ consistent in back shop wired and 60-70 wireless @ about 500’…:person_shrugging:

I dont know why SS wont connect wired its strange.

Im wondering if its the router? I believe im plugged into back of router and not modem. Id have to double check that. Maybe something with SS my ASUS router dont like?? IPVan connected no issues.

My apologies, I overlooked the number you posted above. I have both wifi and wired devices running Surfshark with no issue. I cant think of any setting that would create an issue like this. I also have an Asus router and it works flawlessly with the setup you are describing.

I have a Mecool KM2 in living room and have never run Ethernet to it. I think I will tonight and see what happens when I run SS with it. I’ll report back later this evening

I was just thinking that. I have never used the ethernet on my Mecools.

1 Like

Thanx for helping. Just frustrated. Im completely lost on why it wont connect.

If you have wifi then you’re plugged into one of the 4 ethernet ports on your router…there’s only one on a modem. If you’re getting signal on your devices with current configuration then everything is proper, so I’d take that off the table. ASUS are excellent routers so I don’t believe your problem is there either…no setting tweaks needed for VPNs that I’m aware of…but @TXRon is the resident ASUS guy so he would be better for that answer.

Very impressed that you got Comcast to run a drop of that length to your house…which by the way is the maximum for any cable drop from service tap to a home. 325’ is max for RG11 coax…I’ve done several & they are a real pain in the buttocks for the installer…guessing your have a bump pole located somewhere around halfway from the street to the house…? Your house amp is probably working hard…

Thank you kind sir

Mines the white box i forgot model has netflix and prime pre installed.

Ill have to get model number when i get hime.

Thing is IPVan worked flawlessly.

I also have a Mecool…KM6 with a 1G e-port…works fine.

You are correct. The size cable they ran from the grey box thingy halfway to house was massive! Yes booster has burned out twice. They just come out and change it.

Have you uninstalled and reinstalled Surfshark app? (Sorry if I missed it if you said that)

It just doesnt make sense why the same box in the same spot will connect to wifi when he pulls out the ethernet cord. All physical cable stuff aside, you would think if that were the main issue the wifi would be screwed too.