Can’t play anything on filmplus

I having been using Filmplus for about a year on my nvidia and I updated it the other day and nothing plays. I choose a show, click and it says, “BPLAYER Best Player to work with Filmplus” then it has cancel and install. If I cancel it takes back to same place if I click install it says my device is hit compatible. What do I do?

I just did the update in FilmPlus and it no longer allows you to use another player like MX player. It forces you to download it own player. That’s the problem

1 Like

How do I download it? It says it’s not compatible


I just used MX Pro player on Film+ & it worked fine…version 1.5.1 :cowboy_hat_face:

Is there a newer version?

Yup. 1.5.5 but what I haven’t seen are those using the 1.5.4 mod. I wonder how well it works.

OK…thnx…I’ll slap the newer version on my onn :eyes: & see what happens. I’ll go to APK Pure & see if I can start with the 1.5.4 version & let you know.

Techbigs has a 1.5.5 ad free mod


@deansvh I just updated to version 1.5.5 & clicked on a couple of different streams using my MX Pro player…it loaded & played the same as earlier versions…so not sure what’s going on with y’all’s :thinking:

@Miki Couldn’t find version 1.5.4 so no idea :face_with_diagonal_mouth:

Update: Evidently, all versions after 1.5.5 do not show an external player option. Have not verified, but that has been posted on another thread.

1 Like

I don’t have or use FilmPlus. I’m a dedicated St**mio guy. I just found the APKs and mods. Mod 1.5.4 was on another site. I figured the mod 1.5.5 wouldn’t be much different.

1 Like

Film+ is my 2nd back up of 3 total…St***/Bee/Film/Tea…I have had some issues acquiring streams with my St*** lately…but I’m really thinking its my Surfshark that’s the culprit…but who knows :thinking:

I just tried it it again and it gave me a choice, so I was able to choose the correct player. All good now. Thanks

1 Like

Me too. I’ve been having issues with ST**MIO as well. Actually problems with the RD links. Bad movie links even some older movies with no seeders. Very odd.


That’s right…I now remember someone posted about this a week or so ago & when you chimed in, & were using a different vpn, we crossed SS off as being the culprit.

1 Like

I got it to work, my bad.

I’m having the same problem. I can’t get Real Debrid on Film Plus even though my account is still active. Can someone help me rectify this problem? Thanks in advance.

The Film Plus 1.5.7 mod on works, it disables the pop-up for Bplayer only, and restores player options in settings.

1 Like

I tried this link but it doesnt download for firestick. Is there a download site where i can get this bplayer free version of film+?

I just installed it on my 4k Max. I had to uninstall the v1.5.5 first but it worked. As soon as the “home” page loads hit the magnifying glass and search for Film+ , when your results pop up, scroll down and click on the FilmPlus Mod APK line, this will open the actual download link page, scroll down and click Download FilmPlus Mod APK (Direct Link) , then for the Mod click the blue Download FilmPlus - APK (18.42 MB) and that’s all folks.


Thank you Miki, ill try that. I uninstalled film+ earlier today because of that awful beeplayer it wants to install and installed an older version from Filelinked ( the apk place that troy had on his site that was recently shut down and removed :pensive:) It works and doesn’t ask to install beeplayer…yet… but ill try apk4all for the newer version. Thanks again!

The new modded apk works perfectly for me. Easily reenabled RD on it, although it took a minute or so for the RD links to display. I use VLC as my player of choice all the time(Play With).