BuzzTV X5 appears to be "quitting apps"?

Hello all,

I have had a BuzzTV X5 AI 128 for less than a week. Things appeared to be going well until Tuesday when all of a sudden apps won’t play for longer than 5 minutes. The apps range from Kodi to Plex to Pluto they all seem to crash after about 5 minutes.

I am curious if there is a setting somewhere that I need to change that might be causing this or if someone has any ideas on how I can fix this.

by crash you mean stop working? all apps do exact same thing?

Are you using a VPN…is it Nord?

Yes, the apps stop working.
yes they all do the exact same thing

  1. I launch the app
  2. I play a channel
  3. Channel plays anywhere from 1-5 minutes
  4. The app quits. Not the channel stops playing but the app fully shuts down and I need to relaunch it.

In the case of Kodi, I try to take a look at the log file to see if anything weird is going on but the log file is empty which I had not seen before. Usually, there is at least all the start-up stuff in there.

1 Like

Yes, I am definitely using a VPN. I am using Sufshark. I did try changing that to a couple of different areas but no luck. I have also tried reconnecting to the same area as well as several reboots of the X5.

1 Like

Copy that Vell…ok then…2nd thing that comes to mind for me is a possible power problem…either your power adapter (which should be plugged into an outlet or power strip…not tv usb) or the power cable itself. Is there any way you can swap it/them out with similar ones…ie: same volt/amp/wattage? That would be one thing to try…also, make sure box isn’t too hot…but I doubt that’s the problem if it only takes 5 minutes. Note: power supply cables/adapters are pretty much universal…if rated the same, they will generally work amongst a wide variety of devices.

I have this box, i will play around. But also run a check for malware in the meantime. When the apps stop working does the box shut off or reboot?


So far i haven’t had any issues with the box stopping apps. I’d suggest to clean caches and close background apps as well.

1 Like


I am connected to a USB port on my power strip versus using the included power supply adapter (and plugged into an outlet) that came with the device. I can definitely switch to using the included power adapter and see if that improves things. I will keep you posted once I get a chance to do that.

1 Like

I have cleaned caches and stopped background apps constantly.

I did think malware/viruses might possibly be an issue but I can’t seem to find what a good option is for detecting if that is the case.

May I ask what you are using or what you suggest for this?

I’ll let Dracoo answer his own questions…but I use VirusTotal often & Malwarebytes, occasionally.

Another thing you can try to discount any power setup problem…would be to just connect another device on it & see if the apps hang in there or disappear on you. That would exclude everything but the new box itself & the apps on it.

1 Like

I agree with this, its what i use. I also have premium Malwarebytes.

1 Like

Thanks guys, I will definitely get those.

I will report back once I run a scan and change the power setup.

I believe I have an RPi plugged into a USB outlet and it complains about not having enough power at times so I don’t think its far-fetched to believe that it might be a cause of the issue.

1 Like

i just quickly tried to install both malwarebytes and virustotal but the google play store doesn’t seem to have either of them available. I went to both sites to see if I can sideload them but they point me to the web version of the google play store which then tells me my device is not eligible/compatible?

How did you guys manage to get these apps on your device?


I’m laying money on the fact that your USB strip plug does not provide ample power. I plug my devices straight into the USB adapter(brick) and cord provided by the Manufacturer. Check your device power requirements and then check what the strip is providing.


I just plugged the x5 into the powerstrip using the brick that it came with and I am letting it run while I am working to see if it indeed does continue to close apps. I will definitely keep you guys posted.


I bet you that was it… These things need power.

After changing the power from USB to the brick I ran pluto for about 20 minutes and it didn’t seemed to be fine. I decided to run a movie using Kodi and it crashed. I will have to mess around with it a little bit more later today to see if its just Kodi. It will also give me time to run those virus utilities to eliminate that as an issue.


I was able to run malwarebytes. It told be I didn’t have any issues. Ran the Pluto Tv app for a while and it didn’t crash or exit unexpectedly. Kodi on the other hand still continues to crash which is a separate issue from this post.

I think it’s safe to say plugging the x5 into a power outlet has stabilized it to where everything didn’t quit unexpectedly.

Thanks for all the suggestions. I really appreciate it.


I’m glad its working. But when getting these devices even a firestick always make sure they are plugged in getting direct power from an outlet and power brick.

As far as kodi goes, i haven’t used it heavily, but i plan on using kodi and a bunch more this weekend as well. My buzzbox hasn’t had a single issue yet so its hard for me to say. Sometimes its a install issue or a personal error. But things do happen. Im doing a more deeper dive this weekend. Kodi didnt crash for me yet, and thats using 19-20