Builds that work on Kodi 19.3

I just updated my Kodi 18.9 to 19.3. I followed the SUPERCHARGE GUIDE and for some reason the Index of /repo/ won’t load the Zip File for Chef Wizard. There is a previous Chef Wizard that gives me an error message when I tried to load it.
It shows that I still have a lot of builds in the addon’s, should I have cleared all the previous stuff out and start from scratch?
If not can someone tell me which Build works on the new 19.3.

Thanks Redsox97


Builds :-1: lol just my opinion


I’ve tried three Builds so far and get the same error message… Should I delete the Kodi and all the Old builds then try again from scratch or just go back to 18.9…

Thanks Redsox97


Every Build only goes as far as load the Repository and gives me the same message… " Can not connect to the Repository… WTF!!!


I wouldn’t use builds, but what I would do is fresh install of kodi 19.3 and install your build.

Remember to make sure the build is capable of 19.


Usually that msg indicates that you possibly typed the file name wrong.
just check, and we can go from there.

1 Like

I did a total reinstall and it works perfectly.

I did a fresh install and it didn’t work for me … Super charge link doesn’t work - tried yesterday and again today -Index of /repo/ It downloaded but went to install from Repo ( Diggz Matrix Repository ) it says it can not connect - don’t know what to do ?


Welcome to our community!!!

Guide for Diggs build.

Watch the video in there.

Sounds like the source you put in is wrong or has a typo.


I double check several times to make sure I don’t put in the wrong address Index of /repo/ It downloaded but went to install from Repo ( Diggz Matrix Repository ) it says it can not connect - don’t know what to do ?

1 Like

OK I followed instructions and it is installing Diggz Xenon Free Plus because I don’t have any of the other Diggz Xenon options they offered - in the Chef Wizard list

I also just updated to 19.3 on xbox… I’ve tried installing diggz matrix build and I only get as far as chef wizard.
.it will not let me install or run the wizard

1 Like

That’s what I put on my Kodi
It works perfectly.

1 Like

Same exact thing here. Wizard crashes. So it’s not you…

That’s because you are clicking the wrong one use the left hand side and it will work.

Newly installed Kodi 19.3
Troypoint Supercharge Guide installation
Streaming device: Amazon Fire Stick 4k.

The initial set up path address is different from TroyPoint video guide; input updated address path but noticed through the installation the zip file used appeared to use “diggz” rather than “grump repo” and although I completed the step by step guide, afterwards I experienced multiple issues with the restart and program updates; and Kodi woud not launch or and when it did it would freeze and I noticed that the Fire Stick 4k menu of apps on the home page were no longer visible and although after re-starting the Fire Stick apps would temporarily reappear and work except during activation of Kodi then the issues would repeat.

Please help.


When I tried to install 19.3 on my 4K from the installer it was installing 19.2 instead,I tried on numerous accasions with the same outcmome.
The best way I found to install it on the 4k was via downloader>
it installed 19.3 which installed and ran just fine.

1 Like


If your having that much hardware issues with the stick that leads me to believe you might need to clean your stick.

Remove unnecessary apps.
Clean cache
Debloat your stick if you can

There is a tool in unlinked. Unplug it let it rest plug it in clean it up restart and install kodi 19.3 from troypoint. (Remove all older traces)

Kodi builds do take up resources and the ram for the stick isn’t as good. Especially if over loaded.

I’d fully recommend a clean kodi. Kodi with crew seren oath.

No need for a build, with real debrid on the crew and seren you won’t have content issues.


Dracoo. I am a newbie. This has been a learning curve for sure…I’ve been reading post and consuming a lot of info; Apologies though…I’m not sure what you mean by unlinked and a tool and unplugged. I’ve accomplished your advice leading up to that. I checked out unlinked and browsed tools and utilities but confused. I’m not up to speed on the terms and jargon yet so having some issues interpreting. Thanks for you help.

1 Like