Buffering - Not the usual problem

I have 2 Nvidia Shield Pro’s with the latest updates and SanDisk 128GB Extreme PRO USB 3.2 installed as internal drives. All the apps I loaded are installed on the SanDisk except Syncler. I don’t know why Syncler automatically installs on the Shield directly. In any event, no matter what I stream on KODI, Syncler or Cinema, it buffers constantly. The folks at Nvidia have no idea why it happens on both Shields and they say it ‘appears’ that my Shields are the only ones this is occurring on.
Also, when I installed the flash drives I got the warning message from the Shields that, “The drives are too slow”. They’re 3.2 and super fast. Again, the folks at Nvidia have no idea why I’m getting the warning - they say just ignore it.
By the way, I have 12G space on the Shield’s and 126 G of space on the Nvidia. I don’t know what the amount of cache is (I assume that is where the streams go to for playing and buffer if they run out of space) is either the Shield or the SanDisk. Whatever it is, it should certainly be enough to handle a 1080p movie, right?
I should also add that my download speed (I check often) is always over 200 - I pay for 600, but that is before the VPN.
I’ve set the Shields USB mode to max and under USB Port Power checked the two options to On. I have also changed the “Logger buffer size” from 64K to 16M but that didn’t do the trick either. I’m at my wits end. CAN ANYBODY HELP, PLEASE!

Several things to check, start simple and swap out the hdmi cable with a good data one

When encountering buffering please take a look here, lots of info.

1 Like

Hey TXRon and TP-Draco.
Thank you for your quick replies. Just after your replies were received, I posted an update to my original post adding more info. TXRon: I will change the cable just to be sure, but remember this is happening on not 1, not 2, but 3 Nvidia Shield Pros. The cable can’t be bad on all of them, but it is a good suggestion.
TP-Draco: My NordVPN is set properly and this buffering issue is relatively new and didn’t start until I had the Shield’s well over 9 months. I am using 5ghz and as I mentioned in my update, I never have less than 200 Download.

I would also put my most streamed apps on the shield memory unless for some reason you cant. Also since this is new and the same across multiple devices I would lean toward a network issue. I know uou say DL speeds are good but its worth checking. Depending on your vpn setup start with protocols and then dns settings.

1 Like

On that note I’d also check to make sure your modem doesn’t have a loose incoming connection.

1 Like

Hi! According to Nvidia, when formatting the USB, it should be listed as an internal drive (along with the Shield), so that is what I have done. That kinda negates putting KODI, Syncler & Cinema on the Shield. Besides, I don’t know how to move an app between Shield and the USB other than formatting the USB as an external or internal drive. How can it be a network issue? I check speed often and it is always above 200, sometimes 300+. What are you suggesting might be an issue with my NordVPN protocols and/or DNS settings?

yes, try changing them and test streaming


Buffering os ether network issue or congestion of the unit in some way.

Cache full
Space full
Memory ussed up
Ram used up

That kind of thing. Just have to pinpoint it. Id uninstall and reinstall on your device and not the sandisk and test again

1 Like

I’ve un and reinstalled probably a dozen times, including Factory Reset thrice. No change.
I also clear the cache on the internal and external drives every day after use AND I use Fast Task Killer to double check all available space is in fact available.

Hey TXRon and TP-Draco.
Again, thank you for your quick replies. I changed all 3 HDMI cables and it did not seem to make a difference. Also, I’ve un and reinstalled a dozen times, including Factory Reset. No change.
I also clear the cache on the internal and external drives every day after use AND I use Fast Task Killer to make all space available.
Remember, this buffering issue is occurring on 3 different Shield’s. The support folks at Nvidia think it might be an OS issue but won’t take the task on to review in depth. In the meantime, I’m stuck. I know you two have spent a fair amount of time making suggestions and it is appreciated. Please don’t stop now. OR, is there a way to rebroadcast the my post so other new folks may have different ideas?
H E L P ! ! !

Have you tried powering off your router for a few minutes and then plugging back in?

@ProBowler You have made no mention if you have done any network troubleshooting. I understand you have cleaned this and that but all the cleaning will not fix a network issue and for me I think thats the real problem. I could be wrong but checking these things are rather simple and waiting on support from a level 1 tech is futile.

1 Like

Did this start happening shortly after the “infamous” Nvidia O/S update problems? Or, is it just recently…

@ProBowler Hi

Are you using Google play to download apps on three devices with the same account?

Of Yes: check for updates clean the cash from google play you will find this in apps settings also restart the router.

Also if you’re experiencing the buffering when playing 4k movie with high gb eg 10GB

Try to play 1080hd movie with lower gb eg 3 or 4GB if the buffering disappears than clean apps cash. Device settings> apps> name of the app> clean cash

If you’re playing the movie from Kodi Add-on than the best way to clean kodi cash from device settings> apps> kodi clean cash

HGMartin: Yes, I have two routers. Arris is my direct connect for Comcast/Infinity internet. I also have a Linksys (FlashRouter) with NordVPN built-in (5Ghz) ethernetted to the Arris that I use for my streaming. Before you even ask, I have run Syncler and KODI movies direct through the Arris without VPN - no difference. Again, the least speed I’ve shown is well over 200, 10 x’s what I need for 4K, BUT I always choose the lowest size file for 1080p because 4K would never play.

Pangaeatech, This issue started long before the update screwup.

Nvidia is still insisting it is my SanDisk 3.2 at fault. When this problem started I was using 32G 3.0 SanDisks. I switched to 64G 3.1 drives and now 128G 3.2. No change along the way. As far as I’m concerned, what Nvidia is expousing is bull#$%&. I 5hink you are right about the networking issue. The problem is I just dont know what to do about it. Part of the reason I know you are on to something is, when a movie buffers on Syncler, I switch the decoder in settings from HW to HW+ and that helps a lot. However, some streams (non-movies like Bill Maher’s Real Time or John Oliver’s Last Week Tonight) lose both audio and video on + so I forced to stay with HW.
Any suggestions about how to diagnose network issues? It’s my Custer’s Last Stand. I dont know what else to do. And of course, thanks again for sticking with this.

Matrix, Thanks for the suggestions. I ONLY stream in 1080p. If I try 4K the movie will take all day to play. As I mentioned earlier, I clean the cache of every app I touch every day and that includes Google Play and using Fast Task Killer to clean up leftovers.

@ProBowler Hi

This is a long story that solved many problems in my devices.

I don’t use external apps to clean the system cash or anything else.

I just use the system build in this is good enough for me because sometimes external apps cleanse in necessary things to this will make the divice slow and buffering to.

Sometimes the cause of the buffering it could be that source and many to many users are watching the same 4k.

Me to when I see the buffering wheel turning to many times I change the 4k with 1080HD movie
with no buffering issue.

Also checking ScanDisc USB if it’s full sometimes it could be the source of the problem. It’s a good idea to remove some saved files.

In some cases formatting the USB will help but be careful of loosing important files

One more thing. In my earlier post I mentioned if you’re using one Google account/Google play
for all three devices. Because in my case I use one Google account for multiple devices.

I use to use external apps to clean the system cashe and all unesecerly cashe files, when I try to watch a movie to many buffering internet connection was good, VPN connection also good except the buffering was annoying.

What seems that Google blocked some internet traffic due to removing some security system files were placed by google account to recognize my devices, when used the external app to clean the cashe, the app also cleaned some of the security system cashe placed by google.

Google send notifications that unknown apps trying to access my account have been blocked those notifications were ignored by me.

After I find out that some access have been blocked. I’ve to reauthorize my devices in my google account and the internet traffic was established I watched 4k movie without any buffering :muscle:

Those were my experience I never use to look into it this way but now I do.