Am I the only one having issues with Firestick and RD?

Am I the only one who has a issue with my Firestick since I added Real Debrid? Two Firesticks were working fine before installing Real Debrid and I’ve tried everything imaginable to get them back on track. Tried resetting and watched numerous videos to help. I think they are toast!

Can you be more specific about what you are seeing? The box wont boot, or a certain app wont work? If it is the latter, what is it doing or saying to you?

Oh, and welcome!

Welcome to the Club! @Miki would probably be the one to chime in on this as he’s a Firestick aficionado and can most likely help if he’s using RD as well

1 Like

Thank you @Streaming429 for the vote of confidence. Much appreciated. I saw this post but chose not to reply until there is more info. Having trouble with a firestick after installing RD is very generic and doesn’t give me a direction to give an answer. What is it doing exactly? Are you getting any error screens? What have you tried? Which Firestick?
Please help us help you.


Yea, rd doesnt cuase issues, nor is if something you install. So more info is needed.

Please review this for all firestick issues and guides, if the following hasn’t worked feel free to ask.

This should resolve most to all issues.

Thank you for responding! I’ve been getting “optimizing system storage and applications” message when I plug in my 2nd generation Firestick. I’ve tried pushing the back button and right click on the Firestick remote at start up to get it to reset. It’s stuck in that loop of the Amazon logo, then Firestick logo and back to “optimizing system storage and applications” I’ve tried plugging the Firestick in without the HDMI adapter, directly to the TV. It’s plugged in directly to the outlet and not a power strip. This didn’t happen until I downloaded Real Debrid to use along with Kodi to stop the buffering. When the first Firestick stopped working, I replaced it with another 2nd Gen Firestick that I had. Downloaded Kodi along with Real Debrid and the Firestick stopped working properly.

1 Like

Oh my. Those sticks are 6 yrs old. Sorry but old tech like this often has issues with the newest apps as they are often not coded to run on such old devices. Sorry to tell you but unlike devices like Nvidia Shield Pro, Firesticks have had upgrade after upgrade and unlike the Shield they needed it as well. What FireTV OS Version are you up to? My recomendation, and I know this may not be to your liking, but for just $35/USD you can buy the latest4K Max which will run all you want much better and without these problems.

Have to give credit where credit is due

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.