Alternate Kodi Installation?

Hi! Hope you are all having a splendid Saturday.

I’ve been using Kodi for years. Never had a problem until I started installing new versions from the Google Play Store, OR until I upgraded past 18. Now I have to reauthorize Real Debrid every time I launch Kodi or I don’t get any streams, or the ones I get are not RD ones. Sometimes Kodi won’t launch at all. When it does it’s really, really slow. It can take 15-20 minutes just to get to watch something. I’m using Nvidia Shield tubes and they are fabulous. It’s not the hardware. Anybody else have this issue?

19.3 works fine with the crew add-on. Delete the app cache and app data then uninstall Kodi. Do a fresh install. Don’t use any builds. Install the crew add-on. Then follow my guide on how to configure the add-on settings for best use.

2 Likes

i use the troypoint 19 fork with diggs zenon for real debrid once you get it all set up it works flawlessly

I uninstalled Kodi and reinstalled it using Downloader and Troypoint’s instructions. reauthorized RD and watched a few hours of content on The Crew and exited Kodi to clear it’s cache on my Shield. Now Kodi will not launch again. The screen goes black and then back to my home screen. This did not happen when I was on 19.1. Restarting the Shield doesn’t fix it. I’m kind of at a loss here. I haven’t used the videos because I’m not having a problem with the speed of Kodi, just keeping it going in general. I’m kind of at a loss here. How can i install 19.1 again? I don’t see that option on Troypoint.

That is strange. Not sure what’s causing that. With the newer system update you do have to go into the device settings and enable unknown sources for each individual app. Did you check to make sure that’s enabled for Kodi?

There is a 19.0 fork of Kodi in the rapid app installer. Try downloading that.

Somewhere on here Troy also posted a link to his collection of APKs for prior Kodi versions. You’ll have to do some digging to find it.

@FutureMagic

Unlinked has the versions last I checked. You can search for it in unlinked.

Found it.

http://mirrors.kodi.tv/releases/android/arm/

1 Like

Yep, I was just checking unlinked and was surprised at the amount of kodi builds located in 12341234.

Those are builds, not the bare bones Kodi APKs. Unless both are in there.

Yes, I enabled unknown sources in the device.

Great! Thank you so much!

1 Like

Good Morning! I just wanted to post my final results on this issue. I ended up resetting my Nvidia Shields completely. Then I reinstalled Kodi using Troypoint’s instructions and Downloader. I reinstalled Venom (which requires 19+) and The Crew and all is working perfectly. I’ve never had anything I installed using Troypoint not perform perfectly and this time was no exception. I will not be using the play store again. Thank you all so much for your help. Have a terrific Thanksgiving.

3 Likes

@FutureMagic

I’m happy to hear it’s working. Sometimes Uninstalling is the best way, pain but works.

Glad to hear it. Have a great Thanksgiving.