YouTube App Unable to Open with Surfshark VPN

I recently purchased Surfshark to replace IP Vanish. I am unable to open YouTube since I changed to Surfshark. Contacted Surfshark and they assigned a Tech Team to the issue. Is anyone else unable to open YouTube after they installed Surfshark or does anyone know of a fix?

You really dont need a vpn with youtube. Try split tunneling

Just to check, I added YouTube to my “run through VPN” list on Surfshark and sure enough it would just spin. I unchecked the box in Surfshark and went to connect and it connected immediately, so my test shows it won’t work running through Surfshark

I am running Surfshark on all my devices. I have SmartTube and YouTube both installed and haven’t been able to connect with either for a couple days. Same problem on my Nvidia Shield and my generic android box. I didn’t have any idea what the problem was until I saw this post. I imediately added both SmartTube and YouTube to the Bypasser app list in Surfshark features, so they would bypass the VPN. I then did a reboot on the android box (not sure if it was necessary). After that, both worked like a charm.
Hope this helps others.

1 Like

After installing Surfshark, I had the same problem.

Following online suggestions, I changed my initial vpn address to another. I selected one from Toronto, Canada. This worked.

Now, I select “fastest location,” and I can access YouTube.

Question: Opening YouTube, it’s clear that my general preferences and “membership” have been retained, but choosing “Search” does not automatically populate previous/habitual searches.

No previous search topics show up.

Even if I type, say “Boston Bruins,” YouTube search will not auto fill that search after I enter a few letters, as it normally does.

If anyone has a solution to this, I’d appreciate it,


Greeting fellow hockey fan. :ice_hockey:

I’ve read your post several times but am unclear. The solution given is access YouTube without VPN.

Are you trying to find an alternative?

Edit: Winnipeg Jets!

Hi mgmantho:
this problem is a tricky one, but is solvable. First question I have is: what system are you using (Firestick, Nvidia, Buzztv or what have you)? I’m running the Buzztv system and found out that if shut it down at night (complete shutdown so it needs a reboot at startup) that I could not run Youtube with the SurfShark running. When I let everything “sleep” at night, it worked fine every time I restarted it. My Buzztv was shutting down completely when I shut it down and that’s how I discovered this problem. I had to change the settings in the Buzztv so that it went to “sleep” instead of shutting down. If you do loose power or shut your system down then you need to change the city in you SurfShark to get youtube to run, but you can change it back to whichever city you want after. Hopefully this will help you and it you need to change the settings in you Buzztv for sleep mode shutdown let me know.


I neglected to mention that I use the Amazon Firestick (an old one). My “solution” was to disconnet Surfshark. Then I changed the VPN location from Boston to Toronto. This solved the YouTube access problem without disconnecting from Surfshark.

Later, as noted, I simply hit “Fastest Location” – also in Boston – and also gained access.

Hope that answers your question.

Good luck with Rick Bowness, a good coach (better than Maurice) who is, unfortunately, behind the times. :ice_hockey: :sunglasses:

1 Like

Thank you for the kind words on our coaching change. Playing catch up.

This topic was automatically closed after 17 hours. New replies are no longer allowed.